powernowd fails to start

Help with using MiniMyth (except Booting)

Moderator: Pablo

Post Reply
GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

powernowd fails to start

Post by GloomyTrousers » Fri Jul 31, 2009 11:57 am

Hi all,

Just playing with my new Minimyth install, and I happened to notice that the CPU was running at full speed and powernowd was not running, despite having "MM_CPU_FREQUENCY_GOVERNOR='userspace'" in minimyth.conf.

I can see it attempting to start during boot...

Code: Select all

Jul 31 11:35:14 hoki powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
Jul 31 11:35:14 hoki powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
... but it obviously fails, and when run manually I get...

Code: Select all

root@hoki:~ # powernowd 
powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq: No such file or directory

PowerNowd encountered and error and could not start.
Please make sure that:
 - You are running a v2.6.7 kernel or later
 - That you have sysfs mounted /sys
 - That you have the core cpufreq and cpufreq-userspace
   modules loaded into your kernel
 - That you have the cpufreq driver for your cpu loaded,
   (for example: powernow-k7), and that it works. Check
   'dmesg' for errors.
If all of the above are true, and you still have problems,
please email the author: clemej@alum.rpi.edu
After a bit of experimentation I tried "modprobe powernow-k8" and powernowd starts successfully and clocks my CPU down correctly:

Code: Select all

root@hoki:~ # powernowd 
powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
powernowd:   cpu0: 1000Mhz - 2200Mhz (4 steps)

Code: Select all

Jul 31 11:38:39 hoki kernel: processor ACPI_CPU:00: registered as cooling_device0
Jul 31 11:38:39 hoki kernel: powernow-k8: Found 1 AMD Sempron(tm) Processor LE-1250 processors (1 cpu cores) (version 2.20.00)
Jul 31 11:38:39 hoki kernel: powernow-k8:    0 : fid 0xe (2200 MHz), vid 0xa
Jul 31 11:38:39 hoki kernel: powernow-k8:    1 : fid 0xc (2000 MHz), vid 0xc
Jul 31 11:38:39 hoki kernel: powernow-k8:    2 : fid 0xa (1800 MHz), vid 0xe
Jul 31 11:38:39 hoki kernel: powernow-k8:    3 : fid 0x2 (1000 MHz), vid 0x12
Jul 31 11:38:48 hoki powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
Jul 31 11:38:48 hoki powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
Jul 31 11:38:48 hoki powernowd:   cpu0: 1000Mhz - 2200Mhz (4 steps)
Jul 31 11:38:51 hoki kernel: Clocksource tsc unstable (delta = -68840317 ns)
Is this kernel module not being loaded because my CPU (AMD Sempron LE-1250, 2.2GHz) is not being detected correctly, or is something amiss in my config?

Thanks,

Russ

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: powernowd fails to start

Post by Pablo » Fri Jul 31, 2009 3:14 pm

It is possible that it is not being detected.

What is the value of MM_CPU_KERNEL_MODULE_LIST in '/etc/conf.d/minimyth'?

If you run the following two commands

Code: Select all

modprobe powernow-k8
echo $?
what is the output?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

Re: powernowd fails to start

Post by GloomyTrousers » Fri Jul 31, 2009 7:21 pm

Hi Pablo,

Looks like the module is in the list but not loaded!

Code: Select all

root@hoki:~ # grep MM_CPU_KERNEL_MODULE_LIST /etc/conf.d/minimyth
MM_CPU_KERNEL_MODULE_LIST='powernow-k8 cpufreq-userspace'
root@hoki:~ # lsmod | grep powernow
root@hoki:~ # modprobe powernow-k8
root@hoki:~ # echo $?
0
root@hoki:~ # lsmod | grep powernow
powernow_k8            12024  0 
freq_table              3384  1 powernow_k8
processor              35312  1 powernow_k8
Regards,

Russ

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: powernowd fails to start

Post by Pablo » Sat Aug 01, 2009 2:54 pm

Odd, what is the value of MM_HARDWARE_KERNEL_MODULE_LIST in /etc/conf.d/minimyth?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

Re: powernowd fails to start

Post by GloomyTrousers » Sat Aug 01, 2009 3:46 pm

Hi Pablo,

Code: Select all

root@hoki:~ # grep MM_HARDWARE_KERNEL_MODULE_LIST /etc/conf.d/minimyth
MM_HARDWARE_KERNEL_MODULE_LIST='cpufreq-userspace nvidia powernow-k8'
Regards,

Russ

GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

Re: powernowd fails to start

Post by GloomyTrousers » Sun Aug 30, 2009 10:48 am

Hi Pablo,

Any further thoughts on this? Any other info I can provide?

Thanks,

Russ

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: powernowd fails to start

Post by Pablo » Sat Sep 05, 2009 3:10 am

Sorry, I have not been able to think of anything that might be causing this.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

ph0t0nix
Member
Posts: 34
Joined: Sat Apr 07, 2007 5:36 pm
Location: Europe

Re: powernowd fails to start

Post by ph0t0nix » Sun Oct 25, 2009 7:24 pm

Same situation here. Both on 0.21-68 and 0.21-70.
I'm using an Asus Pundit P1-AH2 Barebone with an AMD Athlon64 3500+ processor. As the topic starter says, reload the powernow-k8 module and then starting powernowd makes it work.

GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

Re: powernowd fails to start

Post by GloomyTrousers » Fri Jan 01, 2010 9:10 pm

Hi all,

Just confirming I still see this on 0.22.0-73b2 (x86_64).

This is what I see in syslog on startup:

Code: Select all

Jan  1 16:32:42 hoki kernel: powernow-k8:    1 : fid 0xc (2000 MHz), vid 0xc
Jan  1 16:32:42 hoki kernel: powernow-k8:    2 : fid 0xa (1800 MHz), vid 0xe
Jan  1 16:32:42 hoki kernel: powernow-k8:    3 : fid 0x2 (1000 MHz), vid 0x12
Jan  1 16:32:43 hoki powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
Jan  1 16:32:43 hoki powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
This is what I see if I manually run "modprobe powernow-k8" then "powernowd"

Code: Select all

Jan  1 19:49:30 hoki kernel: powernow-k8: Found 1 AMD Sempron(tm) Processor LE-1250 processors (1 cpu cores) (version 2.20.00)
Jan  1 19:49:30 hoki kernel: powernow-k8:    0 : fid 0xe (2200 MHz), vid 0xa
Jan  1 19:49:30 hoki kernel: powernow-k8:    1 : fid 0xc (2000 MHz), vid 0xc
Jan  1 19:49:30 hoki kernel: powernow-k8:    2 : fid 0xa (1800 MHz), vid 0xe
Jan  1 19:49:30 hoki kernel: powernow-k8:    3 : fid 0x2 (1000 MHz), vid 0x12
Jan  1 19:49:43 hoki powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
Jan  1 19:49:43 hoki powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
Jan  1 19:49:43 hoki powernowd:   cpu0: 1000Mhz - 2200Mhz (4 steps)
Not sure why there's this difference, but does it help track down the issue?

Russ

GloomyTrousers
Member
Posts: 25
Joined: Tue Jul 28, 2009 8:11 pm
Location: York,UK
Contact:

Re: powernowd fails to start

Post by GloomyTrousers » Sun Jan 27, 2013 8:43 pm

Hi Pablo,

It's been a while... I'm now on 0.26.0-83b1-x86_64. Despite settings still as above, powernowd isn't starting. So, I put this hack in the start() sub in my minimyth.pm:

Code: Select all

system("powernowd");
It still fails to start, but I get this at the top of /var/log/minimyth.log:

Code: Select all

powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
powernowd: Found 1 scalable unit:  -- 1 'CPU' per scalable unit
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq: No such file or directory

PowerNowd encountered and error and could not start.
Please make sure that:
 - You are running a v2.6.7 kernel or later
 - That you have sysfs mounted /sys
 - That you have the core cpufreq and cpufreq-userspace
   modules loaded into your kernel
 - That you have the cpufreq driver for your cpu loaded,
   (for example: powernow-k7), and that it works. Check
   'dmesg' for errors.
If all of the above are true, and you still have problems,
please email the author: clemej@alum.rpi.edu
Logging on and starting it after the box is up works fine, so that 3rd line made me think: is it not starting correctly normally (i.e. without my minimyth.pm hack) because the normal startup also attempts to start it before /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq is available?

I don't know enough about the startup sequence to know if this is right, but thought I'd raise it as a possibility.

Regards,

Russ

Post Reply