0.25.0-80 and atiusb

Help with using MiniMyth (except Booting)

Moderator: Pablo

Post Reply
jangi
Contributor
Posts: 137
Joined: Mon Nov 13, 2006 10:50 pm

0.25.0-80 and atiusb

Post by jangi » Mon Apr 30, 2012 7:40 am

I decided to give 0.25 a shot (as well as mm80) and am happy to report my main frontend works great.

Unfortunately my remote control on another frontend isn't so happy. See the thread below for problems I've had in past upgrades:
viewtopic.php?f=1&t=2791

/dev/lirc0 is never created, lircd isn't started, and there are no errors in /var/log/messages.

Code: Select all

root@myth1:~ # grep atiusb /var/log/messages
Apr 30 02:29:57 (none) user.info kernel: lirc_atiusb: USB remote driver for LIRC $Revision: 1.88 $
Apr 30 02:29:57 (none) user.warn kernel: lirc_atiusb: Paul Miller <pmiller9@users.sourceforge.net>
Apr 30 02:29:57 (none) user.info kernel: usbcore: registered new interface driver lirc_atiusb

root@myth1:~ # grep lirc /var/log/messages
Apr 30 02:29:57 (none) user.info kernel: lirc_dev: IR Remote Control driver registered, major 252
Apr 30 02:29:57 (none) user.info kernel: lirc_atiusb: USB remote driver for LIRC $Revision: 1.88 $
Apr 30 02:29:57 (none) user.warn kernel: lirc_atiusb: Paul Miller <pmiller9@users.sourceforge.net>
Apr 30 02:29:57 (none) user.info kernel: usbcore: registered new interface driver lirc_atiusb
Apr 30 02:30:05 (none) user.info kernel: input: eventlircd as /devices/virtual/input/input4
Apr 30 02:30:11 (none) local0.info mythfrontend: 2012-04-30 02:30:11.672815 I  LIRC: Successfully initialized '/var/run/lirc/lircd' using '/home/minimyth/.mythtv/lircrc' config

root@myth1:~ # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0bc7:0002 X10 Wireless Technology, Inc. Firecracker Interface (ACPI-compliant)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Guess the dust is still settling with lirc/devinput. Or maybe I'm missing something, which would actually be great. :D

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: 0.25.0-80 and atiusb

Post by Pablo » Tue May 01, 2012 8:00 pm

Does the latest test build (0.25.0-81b3) work?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

jangi
Contributor
Posts: 137
Joined: Mon Nov 13, 2006 10:50 pm

Re: 0.25.0-80 and atiusb

Post by jangi » Tue May 01, 2012 8:52 pm

I won't be home for a few hours... but I did upload the test version and reboot remotely and /dev/lirc0 is now created, which is a good sign. I'll let you know if the remote works later tonight.

Any chance the beta build also fixes a color problem with an integrated intel graphics card? I'll start a new topic if it doesn't.

Thanks!

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: 0.25.0-80 and atiusb

Post by Pablo » Wed May 02, 2012 12:10 am

jangi wrote:I won't be home for a few hours... but I did upload the test version and reboot remotely and /dev/lirc0 is now created, which is a good sign. I'll let you know if the remote works later tonight.
Thank you.
Any chance the beta build also fixes a color problem with an integrated intel graphics card? I'll start a new topic if it doesn't.
There is good news and bad news. A couple days ago, Intel released an updated Xorg video driver that fixes several problems and they strongly urge people to upgrade. However, this is on in 81b3 (but it will be in 81b4).
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

jangi
Contributor
Posts: 137
Joined: Mon Nov 13, 2006 10:50 pm

Re: 0.25.0-80 and atiusb

Post by jangi » Wed May 02, 2012 12:19 am

Remote works, thank you!

Strangely enough, the video problem was fixed too...

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: 0.25.0-80 and atiusb

Post by Pablo » Thu May 10, 2012 12:20 am

Could you try the latest test build (0.25.0-81b4)?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

jangi
Contributor
Posts: 137
Joined: Mon Nov 13, 2006 10:50 pm

Re: 0.25.0-80 and atiusb

Post by jangi » Thu May 10, 2012 2:07 am

Nope, looks like 81b4 regressed. Can I help troubleshoot?

jangi
Contributor
Posts: 137
Joined: Mon Nov 13, 2006 10:50 pm

Re: 0.25.0-80 and atiusb

Post by jangi » Sat Sep 08, 2012 2:38 am

Pablo,

Any chance the fix you put in for atiusb in 81b3 can be made permanent? 81b4 and 81 final both don't work for me.

Thanks

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: 0.25.0-80 and atiusb

Post by Pablo » Thu Nov 29, 2012 2:03 am

My ATI remote works with MiniMyth 82.

Could you give it a try?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply