latest nvidia 304.43 & refresh autochange ?

Help with using MiniMyth (except Booting)

Moderator: Pablo

Post Reply
warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

latest nvidia 304.43 & refresh autochange ?

Post by warpme » Tue Aug 28, 2012 10:12 am

Hi Pablo

I saw You changed default nvidida to 304.43.
In my case upgrading from 295.59->304.43 has the same issue like described in http://www.nvnews.net/vbulletin/showthread.php?t=187844
Have You correctly working 304.43 in Your system ? (I mean have You automatically changed refresh on TV when You i.e. move from 60fps to 23,976fps content)

JoeHenley
Contributor
Posts: 185
Joined: Sun Aug 06, 2006 4:12 pm

Re: latest nvidia 304.43 & refresh autochange ?

Post by JoeHenley » Tue Aug 28, 2012 9:29 pm

Hi warpme,

Where did you see that -- about the newer version of the nvidia drivers? I have looked all over the site and can't find it. I have lots of problems with 295.59, so I'd like to try the 304.x version.

Thanks!

Joe Henley

warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

Re: latest nvidia 304.43 & refresh autochange ?

Post by warpme » Tue Aug 28, 2012 9:43 pm


JoeHenley
Contributor
Posts: 185
Joined: Sun Aug 06, 2006 4:12 pm

Re: latest nvidia 304.43 & refresh autochange ?

Post by JoeHenley » Wed Aug 29, 2012 4:22 am

Hi warpme,

Oh, I misunderstood. I thought you had seen it compiled for use in a recent MiniMyth version.

But, from what you said, have you made the 304.43 version work in MM?

Thanks!

Joe Henley

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: latest nvidia 304.43 & refresh autochange ?

Post by Pablo » Thu Nov 29, 2012 2:00 am

I do not recall whether or not I had problems with 304.43. Does MiniMyth 82 work? It has 310.19 and works for me on my Ion system.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

Re: latest nvidia 304.43 & refresh autochange ?

Post by warpme » Thu Nov 29, 2012 1:56 pm

Pablo,
Are You sure that 310.19 works ok for all refresh rates (23,976, 25, 50 & 60)
For me it looks like 310.x autorefresh works but:
-not for all refreshes.
-some of them are mixed (I've got ie 60 for 23,976).
I'm on svn r9099 so I don't know it is working for r81 or not.
But assuming that You, for move from 295.x->3xx.x, change only strictly nvidia related parts of gar - my sys should be similar to Yours as I do the same.
Why ten 310.x works OK for You but not for me is mystery for me.
I have problem with all nvidia above 295* family...

br

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: latest nvidia 304.43 & refresh autochange ?

Post by Pablo » Thu Nov 29, 2012 4:03 pm

warpme wrote:Pablo,
Are You sure that 310.19 works ok for all refresh rates (23,976, 25, 50 & 60)
I only know that 310.19 works with my refresh rate (60Hz) on my hardware.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

cheesy
Member
Posts: 16
Joined: Tue Apr 24, 2012 3:24 am

Re: latest nvidia 304.43 & refresh autochange ?

Post by cheesy » Mon Jul 08, 2013 2:27 am

I'd been having this with newer minimyth builds and it finally got on my nerves enough to look into it. After messing around with this for several hours, I discovered that the problem was a pretty dumb mistake in my xorg.conf; The VertRefresh on my Monitor was incorrect! My xorg.conf had:

Code: Select all

VertRefresh 58.0-62.0
Previous nVidia drivers seemed to have been OK with, but I guess no-longer. I just flipped the VertRefresh to 23-62 and suddenly my problems were fixed!

Might be worth looking into warpme, if you are still around ;)

warpme
Contributor
Posts: 438
Joined: Fri Aug 26, 2005 8:17 pm

Re: latest nvidia 304.43 & refresh autochange ?

Post by warpme » Mon Jul 08, 2013 10:52 am

@Cheesy,

Thx for memories about this issue and post. Some time ago I found (by accident) exactly what You found.
319.23 are working beautifully for me.
BTW: 300+ family of nvidia drivers have issue causing unnecessary mode switches. It was fixed in mythtv code sometime ago:
https://github.com/MythTV/mythtv/commit ... bd5e0bdac8
It is worth to have mm with this commit as with it mode switches are working really smooth :-)
br

cheesy
Member
Posts: 16
Joined: Tue Apr 24, 2012 3:24 am

Re: latest nvidia 304.43 & refresh autochange ?

Post by cheesy » Mon Jul 08, 2013 4:50 pm

Interesting. It looks like that was pulled into 0.26+fixes, so I guess if Pablo ever pulls a new mythtv, we'll see that in mm.

I'm actually building minimyth myself now just as an exercise, so maybe I'll try pulling that patch and see if it makes a difference.

Post Reply