kernel panic when booting "mkcramfs" image

Help with booting MiniMyth

Moderator: Pablo

Post Reply
lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

kernel panic when booting "mkcramfs" image

Post by lmatter » Fri Aug 29, 2003 6:01 pm

(copying this from another thread)
Hairlocks said:

sorted the gid bit problem, doing a chown root:root does it. As for the error messages I get


VFS mounted root cramfs filesystem
Mounted devfs on /dev
Error -3 while decompressing
c07de94c(0890545092) -> dfc0000(4096)
VFS: cannot open root device "" or 03:03
Please append a correct "root=" boot option
Kernel panic: VFS unable to mount rootfs on 03:03

I did change the ramdisk to 24000 but I will try increasing it again

lmatter
Contributor
Posts: 632
Joined: Sat Aug 23, 2003 5:13 pm
Location: California, USA

Post by lmatter » Fri Aug 29, 2003 6:02 pm

This is a common error when things are not exactly right. Things that I recall to have caused this in the past are:

1) ramdisk_blocksize in the pxelinux.cfg/default file. Should be 4096.
2) do "which mkcramfs" and make sure you are running the one you downloaded.

Can't comment on other distributions; I run Mandrake 9.1 here.

Larry

Hairlocks
Contributor
Posts: 107
Joined: Wed Aug 27, 2003 12:23 pm
Location: Reading, UK
Contact:

Post by Hairlocks » Fri Aug 29, 2003 6:14 pm

Oops, sorry. Redhat 9 comes with mkcramfs, which obviously doesn't work, must of missed it the first time I looked, it works now!

Thanks

Post Reply