minimyth.script broken?

Help with booting MiniMyth

Moderator: Pablo

Post Reply
seth_keith
Contributor
Posts: 131
Joined: Fri Mar 09, 2007 8:13 pm

minimyth.script broken?

Post by seth_keith » Tue Mar 27, 2007 6:20 am

Thought I would try out the .22 release of minimyth on account of I wanted to try the games. However the minimyth.script file does not get copied at boot ( ram fs version ). I looked in /etc/minimyth.d and it was not there. Unfortunately I need this script to function on account of my .xine conf file. Any work around?

While I am at it, I noticed a few other things. Previously ( version .21 ) the MM_NTP_SERVERS setting was optional. Now it is mandatory. I wish my internet connection was reliable enough for mandatory ( thanks Gilat aka Starband :x ) but it is not. I figgured out you can set MM_NTP_SERVERS =' ' and it will work alright to disable NTP, but I really want minimyth to attempt all servers in the list then continue anyway if none are found.

However, if I set MM_NTP_SERVERS='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org'

instead of getting 3 attempts and fail on, I get a failure in 0.pool.ntp.org. I think it only tries the first then fails. I want 3 trys and yer in! I don't have TV after all, and I can live with old weather. Is there a work around for this one?

vbu
Member
Posts: 44
Joined: Tue Apr 18, 2006 3:26 pm

Post by vbu » Tue Mar 27, 2007 3:14 pm

Sorry, can't help with the ntp problems, but I was looking at the changelog for minimyth.conf and saw some new variables, one of which is:

MM_MINIMYTH_FETCH_MINIMYTH_SCRIPT

with this set to 'yes' minimyth should always download your minimyth.script to the frontend.

HTH and that I've read the changelog correctly.

Ver

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: minimyth.script broken?

Post by Pablo » Tue Mar 27, 2007 6:05 pm

seth_keith wrote:Thought I would try out the .22 release of minimyth on account of I wanted to try the games. However the minimyth.script file does not get copied at boot ( ram fs version ). I looked in /etc/minimyth.d and it was not there. Unfortunately I need this script to function on account of my .xine conf file. Any work around?
As vbu pointed out, starting with -22, in order to download a specific miscellaneous configuration file, you must specify the appropriate MM_*_FETCH_* variable in minimyth.conf. This was done to improve error handling. Unfortunately, the transition is somewhat painful.
While I am at it, I noticed a few other things. Previously ( version .21 ) the MM_NTP_SERVERS setting was optional. Now it is mandatory. I wish my internet connection was reliable enough for mandatory ( thanks Gilat aka Starband :x ) but it is not. I figgured out you can set MM_NTP_SERVERS =' ' and it will work alright to disable NTP, but I really want minimyth to attempt all servers in the list then continue anyway if none are found.

However, if I set MM_NTP_SERVERS='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org'

instead of getting 3 attempts and fail on, I get a failure in 0.pool.ntp.org. I think it only tries the first then fails. I want 3 trys and yer in! I don't have TV after all, and I can live with old weather. Is there a work around for this one?
You are right, it fails on the first attempt. I will fix that. The fix will be in the next test release.

Also, I will add the variable MM_NTP_FAILURE_ACTION, that will allow you to override the default action of stopping initialization on NTP failure.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

seth_keith
Contributor
Posts: 131
Joined: Fri Mar 09, 2007 8:13 pm

awsome

Post by seth_keith » Wed Mar 28, 2007 6:45 am

I must say it is truely a pleasure to be working with a distribution where real people actually care about problems and respond quickly. This seems to be the exception rather than the rule. Pablo, thanks again for the hard work.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Thu Mar 29, 2007 2:25 am

It is in the latest test release (0.20-23b9). As mentioned, the variable that controls it is called MM_NTP_FAILURE_ACTION with values of 'fail' and 'continue'. Could you test it?

Note: The MM_MYTH_* variables have been renamed from MM_MYTH_* to MM_MASTER_* in order to reflect the fact that the are for master backend communication.

Also, thanks for the kind words.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

vbu
Member
Posts: 44
Joined: Tue Apr 18, 2006 3:26 pm

Post by vbu » Thu Mar 29, 2007 8:20 am

This is great ! I've been having problems lately with the ntpd service on my main pc flaking out. Being able to have minimyth continue working even though ntp is down would be a godsend.

Thanks Pablo, you're ongoing support of this project is much appreciated.

ph0t0nix
Member
Posts: 34
Joined: Sat Apr 07, 2007 5:36 pm
Location: Europe

Post by ph0t0nix » Mon Apr 09, 2007 4:36 pm

I also have a problem with my minimyth.script. I set the variable MM__MINIMYTH_FETCH_MINIMYTH_SCRIPT='yes' and the script gets downloaded to /etc/minimiyth.d/.
However the contents of the script doesn't get executed. It works when running it (as root) from the command line (sh /etc/minimyth.d/minimyth.script).
On the server I changed the file permissions to be executable, but the copied version in minimyth.d apparently has 644 permissions.

What I try to do is just a simple adjustment to my xine config. This is the contents of my minimyth.script:

Code: Select all

#!/bin/sh 
. /etc/rc.d/functions
/bin/sed -ie 's/:Stereo 2.0/:Pass Through/' /home/minimyth/.xine/config 
What am I missing here?

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Mon Apr 09, 2007 11:42 pm

ph0t0nix wrote:I also have a problem with my minimyth.script. I set the variable MM__MINIMYTH_FETCH_MINIMYTH_SCRIPT='yes' and the script gets downloaded to /etc/minimiyth.d/.
However the contents of the script doesn't get executed. It works when running it (as root) from the command line (sh /etc/minimyth.d/minimyth.script).
On the server I changed the file permissions to be executable, but the copied version in minimyth.d apparently has 644 permissions.

What I try to do is just a simple adjustment to my xine config. This is the contents of my minimyth.script:

Code: Select all

#!/bin/sh 
. /etc/rc.d/functions
/bin/sed -ie 's/:Stereo 2.0/:Pass Through/' /home/minimyth/.xine/config 
What am I missing here?
I believe that your script is running. However, it has nothing to substitute at the time. The Xine config file contains a variable '@SPEAKER_ARRANGEMENT@', which is replaced by the 'audio' init script based on MM_AUDIO_TYPE. Therefore, your sed line needs to be something like.

Code: Select all

#!/bin/sh 
. /etc/rc.d/functions
/bin/sed -ie 's/@SPEAKER_ARRANGEMENT@/Pass Through/' /home/minimyth/.xine/config 
However, setting MM_AUDIO_TYPE='digital' or MM_AUDIO_TYPE='digital+analog' should accomplish the same thing.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

ph0t0nix
Member
Posts: 34
Joined: Sat Apr 07, 2007 5:36 pm
Location: Europe

Post by ph0t0nix » Tue Apr 10, 2007 11:55 pm

Thanks Pablo, setting MM_AUDIO_TYPE as you suggested made it work.

Post Reply