27b6 cause MII12000 to fail at boot (Compact Flash)

Help with booting MiniMyth

Moderator: Pablo

Post Reply
lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

27b6 cause MII12000 to fail at boot (Compact Flash)

Post by lofty69 » Tue Aug 07, 2007 1:11 pm

Just upgraded to 27b6 (from b2) and I'm now getting the following when booting:

loading kernel modules ...

Then at the top of the screen in black..

ata1.00: cmd c8/00:08:00:00:00/00:00:00:00:00/ec tag 0 cdb 0x0 data 4096 in

followed by:

waiting for directory /minimyth to mount ...

then more ata messages that just flash up, followed by:

waiting for directory /minimyth to mount ...

This just now loops.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Tue Aug 07, 2007 7:21 pm

It may be the IDE driver. Could you try 27b7?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Post by lofty69 » Tue Aug 07, 2007 9:24 pm

Hi Pablo,

Tested 27b7 and I can now start myth, however it is still very slow. It sits at waiting for directory /minimyth to mount ... for a long time with the IDE light on. Is DMA disabled for this build as this looks like it is having problems connecting. I will post you the messages log.

Thanks

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Thu Aug 09, 2007 1:23 am

Could you try 27b8?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Post by lofty69 » Thu Aug 09, 2007 8:38 am

Thanks Pablo, all working again.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Thu Aug 09, 2007 4:02 pm

I am glad that it works now.

Using the information from your log file, I added your Compact Flash card to the kernel's DMA blacklist for disk drives.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Post by lofty69 » Sun Aug 12, 2007 10:26 am

Hi Pablo, upgraded my second frontend (EN12000) and have the same issue. I thought they were the same card but they are not. This card shows up as a SDCFH-1024 in /var/log/messages

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Sun Aug 12, 2007 8:42 pm

Could you give the latest test release (0.20.1-28b1) a try?

I have changed how I patch the kernel to handle DMA issues Compact Flash. Instead of using the DMA blacklist, I have patched the kernel so that it disables DMA on all Compact Flash devices connected to an IDE or ATA interface (at least that is the intent of the patch).
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Post by lofty69 » Mon Aug 13, 2007 9:52 am

Thanks Pablo, all works. Excellent support as usual :D

Post Reply