Network Boot - Stopping at "Waiting for directory /mini

Help with booting MiniMyth

Moderator: Pablo

Post Reply
GaryMacMinn
New Member
Posts: 4
Joined: Wed Sep 12, 2007 12:05 am
Location: Brisbane, Australia

Network Boot - Stopping at "Waiting for directory /mini

Post by GaryMacMinn » Wed Sep 12, 2007 12:16 am

Hi All,

As a new MythTV convert I was pleasently suprised to find a full set up, network bootable distro I could use for the front end of my MythTV system.

Trying the latest version of minimyth on a Epia MII board (512M RAM), I have the network boot bit working, kernel and rootfs loading and the system starting to come up.

The problem: when it gets to the message "Waiting for directory /minimyth to mount", that's as far as we go.

Can anyone tell me what exactly this stage is doing? Previous mentions of this type of error have hinted at IDE problems although the EPIA MII is a supported board, I would not have expected problems in this area. I have the IDE disabled in BIOS anyway. When debug is given on the boot line it still seems to locate /dev/hda (HDD has Mythdora on it).

Debug seems to stop around locating USB ports.

Any thoughts?

Thanks,

Gary

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Tue Sep 25, 2007 3:25 am

I suspect that it is a DHCP configuration issue. If MiniMyth does not see the boot_file option (called filename by the ISC DHCP server), then it assumes that it is using local boot. Therefore, for your MiniMyth front end, you need to make sure that this option is provided during DHCP not just BOOTP.

Alternatively, you can add

Code: Select all

MM_BOOT_TYPE=network
to your boot line.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply