Page 1 of 1

FC+VIA EPIA boot - waiting for directory /minimyth to mount

Posted: Mon Oct 29, 2007 6:38 pm
by simon_bagola
Sorry guys, but something strange happened to me...

OK, i used some older stable version, GREAT!

Then, like in some other posts, i had trouble with Eastern Euopen subtitles (not showing

Posted: Mon Oct 29, 2007 8:43 pm
by Pablo
This usually happens when the DHCP server has been configured to provide the boot filename attribute during BOOTP but not during DHCP. MiniMyth uses the presence/absence of this attribute to decide that it is network or local booting. You can either make the change in the DHCP server or add MM_BOOT_TYPE=network on the boot line.

Posted: Mon Oct 29, 2007 9:10 pm
by simon_bagola
hmmm, that's bit strange, because the following minimyth.conf worked fine before:
root@(none):~ $ more /minimyth/conf/default/minimyth.conf
MM_TZ='Europe/Ljubljana'
MM_AUDIO_TYPE='analog'
MM_VIDEO_ASPECT_RATIO='16:9'
#MM_X_MODE='1360x768'
MM_X_MODELINE='Modeline "1024x768" 60.00 1024 1048 1184 1344 768 771 777 806 -Hsync -Vsync'
#MM_X_MODELINE='Modeline "1360x768_60.00" 85.5 1360 1416 1528 1792 768 771 777 795 +Hsync +Vsync'
#MM_X_MODELINE='ModeLine "1280x720_60.00" 74.48 1280 1336 1472 1664 720 721 724 746 -HSync +Vsync'
#MM_X_MODELINE='Modeline "1360x768" 85.50 1360 1424 1536 1792 768 771 777 795 +hs
#
#ync +vsync'
MM_X_OUTPUT_VGA='auto'
MM_MYTH_SERVER='192.168.0.5'
MM_MYTH_DBUSERNAME='mythtv'
MM_MYTH_DBPASSWORD='mythtv'
MM_MYTH_DBNAME='mythconverg'
MM_THEME_NAME='blue'
MM_THEMEOSD_NAME='blueosd'
MM_LIRC_DRIVER='serial'
MM_LIRC_DEVICE='/dev/lirc0'
MM_LIRC_KERNEL_MODULE='lirc_serial'
MM_LIRC_KERNEL_MODULE_OPTIONS='irq=4 io=0x3f8'

MM_DHCP_NTP_SERVERS='goodtime.ijs.si'
MM_HOSTNAME='fanless01'

MM_MYTHDVD_URL='nfs://192.168.0.5/storage/mythdvd'
MM_MYTHGALLERY_URL='nfs://192.168.0.5/storage/pictures'
MM_MYTHMUSIC_URL='nfs://192.168.0.5/storage/music'
MM_MYTHVIDEO_URL='nfs://192.168.0.5/storage/videos'

MM_X_SCREENSAVER='xscreensaver'
MM_X_SCREENSAVER_HACK='glslideshow'

MM_X_WM_ENABLED='yes'
MM_LIRC_FETCH_LIRCD_CONF='yes'
MM_LIRC_FETCH_LIRCRC='yes'

MM_DEBUG='yes'
also, the router is the same as before, nothing else changed... yes, the router is also DHCP server (some D-link WiFi version)

Posted: Mon Oct 29, 2007 10:44 pm
by Pablo
MiniMyth's behavior was changed because of problems detecting local boot.

Are you network or local booting?

Posted: Tue Oct 30, 2007 7:51 am
by simon_bagola
Pablo wrote:
Are you network or local booting?
Local booting Pablo...

Posted: Wed Oct 31, 2007 12:56 am
by simon_bagola
Hi guys... I know, I'm still learning.i managed, to look for a "dhcp" conf.file.. I set it up like follows:
MM_DHCP_ADDRESS='192.168.0.25'
MM_DHCP_HOSTNAME='fanless01'
MM_DHCP_DOMAIN=''
MM_DHCP_DNS_SERVERS='192.168.0.1'
MM_DHCP_NTP_SERVERS='goodtime.ijs.si'
MM_DHCP_LOG_SERVERS=''
MM_DHCP_TZ='Europe/Ljubljana'
MM_TFTP_SERVER=''
MM_TFTP_ROOTDIR=''
MM_BOOT_TYPE='local'
But, still the same problem... Must i change minimyth.conf file now??

Thanks for this NEWBIE helping....

Posted: Wed Oct 31, 2007 7:32 pm
by Pablo
When you telnet in do you see anything useful /var/log/messages? Do you see your device in /dev (likely either /dev/hda or /dev/sda)? Do you see /minimyth?

Posted: Thu Nov 01, 2007 9:48 am
by simon_bagola
Hi!

/var/log/messages gives me an endless list of:
imyth: waiting for directory /minimyth to mount ...
Nov 1 16:43:10 (none) local0.info minimyth: waiting for directory /minimyth to mount ...
Nov 1 16:43:11 (none) local0.info minimyth: waiting for directory /minimyth to mount ...
Nov 1 16:43:13 (none) local0.info minimyth: waiting for directory /minimyth to mount ...
Nov 1 16:43:14 (none) local0.info minimyth: waiting for directory /minimyth to mount ...
then /dev contains:
root@(none):/dev $ ls
agpgart ram4 tty27 tty59
console ram5 tty28 tty6
core ram6 tty29 tty60
fb0 ram7 tty3 tty61
fd ram8 tty30 tty62
full ram9 tty31 tty63
initctl random tty32 tty7
input rtc tty33 tty8
kmem sda tty34 tty9
kmsg shm tty35 urandom
log snd tty36 usb1
loop0 stderr tty37 usb2
loop1 stdin tty38 usb3
loop2 stdout tty39 usb4
loop3 tty tty4 usbdev1.1
loop4 tty0 tty40 usbdev1.1_ep00
loop5 tty1 tty41 usbdev1.1_ep81
loop6 tty10 tty42 usbdev2.1
loop7 tty11 tty43 usbdev2.1_ep00
mem tty12 tty44 usbdev2.1_ep81
null tty13 tty45 usbdev3.1
parport0 tty14 tty46 usbdev3.1_ep00
port tty15 tty47 usbdev3.1_ep81
ptmx tty16 tty48 usbdev4.1
pts tty17 tty49 usbdev4.1_ep00
ram0 tty18 tty5 usbdev4.1_ep81
ram1 tty19 tty50 vcs
ram10 tty2 tty51 vcs1
ram11 tty20 tty52 vcs16
ram12 tty21 tty53 vcsa
ram13 tty22 tty54 vcsa1
ram14 tty23 tty55 vcsa16
ram15 tty24 tty56 zero
ram2 tty25 tty57
ram3 tty26 tty58
and like you see... there is no /mnimyth...
root@(none):/ $ ls
bin etc initrd media proc sbin sys usr
dev home lib mnt root srv tmp var

Posted: Thu Nov 01, 2007 3:24 pm
by Pablo
Assuming the device /dev/sda is the boot device, could you post the output of
udevinfo -q all -n /dev/sda

Posted: Thu Nov 01, 2007 9:08 pm
by simon_bagola
Here is the result:
root@(none):~ $ udevinfo -q all -n /dev/sda
P: /block/sda
N: sda
Thanks for help Pablo!
*****
EDIT: I don't know if that's important, but if i "ls" the "/dev" directory, there is no "sda" indside, it's empty...

Posted: Thu Nov 08, 2007 6:44 am
by Pablo
If /dev/sda is the device, then the output of udevinfo should show the label name for the device. In the next day or so, I will test local boot with the current build. If it works, then I will upload it for you to test on your system.

Posted: Fri Nov 09, 2007 3:50 pm
by Pablo
I have uploaded a new test version. I have tested that it will local boot (on my system at least).

Posted: Sun Nov 25, 2007 11:34 pm
by simon_bagola
Sorry Pablo, didn't have time last few weeks,

I'll try it out, and report.

must say, few weeks ago, i purchased laptop HD and installed MythDora 4.0. Runs OK, the smooth video is a problem... OK, i know, i'm a shame...
:oops: :oops: :oops:
Like i said, i'lll try it out!

THANKS!!!