Hang on starting LCD/VFD

Help with booting MiniMyth

Moderator: Pablo

Post Reply
rbroberts
Contributor
Posts: 61
Joined: Wed Nov 21, 2007 6:27 pm
Location: Brooklyn, NY
Contact:

Hang on starting LCD/VFD

Post by rbroberts » Tue Nov 27, 2007 3:57 pm

First caveat: I've downloaded and am using a nightly snapshot of lcdproc in order to get the driver I need.

LCDd is not going into the background when started. This was also true with the 0.5.2 release that I started out using. It would happily start when forced to use a particular driver (even though it wouldn't write to the VFD), but it would not go into the background. Now I've got the correct driver so it does write to the VFD, but it does not go into the background.

Minimyth 0.20-2.31, 20071125 nightly snaptshot of lcdproc, tftp.c modified for 250ms retries.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed Nov 28, 2007 1:46 am

If you set Foreground=no in the server section of you LCDd.conf file, then does it go to the background?

Do you see anything useful in /var/log/messages?

If you run it from the command line, then do you see any error messages?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

rbroberts
Contributor
Posts: 61
Joined: Wed Nov 21, 2007 6:27 pm
Location: Brooklyn, NY
Contact:

Post by rbroberts » Wed Nov 28, 2007 4:43 am

Unfortunately, the answer to all three is "no" :-(

But I did find what the problem seems to be. It looks like my setting of MM_LCDPROC_DRIVER is not being used. The command line for LCDd is just

Code: Select all

/usr/sbin/LCDd -c /etc/LCDd.conf
When I manually launch as

Code: Select all

/usr/sbin/LCDd -c /etc/LCDd.conf -d lis
It goes into the background. My minimyth.conf looks like this:

Code: Select all

MM_MASTER_SERVER=192.168.3.36
MM_X_OUTPUT_VGA=auto
MM_X_RESOLUTION=1920x1080
#  MM_X_MODE=720x480Noscale
MM_THEME_NAME=blue
MM_THEMEOSD_NAME=blueosd
MM_LDCPROC_DRIVER=lis
MM_LCDPROC_FETCH_LCDD_CONF=yes
The file /etc/LCDd.conf still has

Code: Select all

Driver=@MM_LCDPROC_DRIVER@
as if the sed was not executed.

Hmm, actually this doesn't look right in /etc/rc.d/init.d/lcdproc:

Code: Select all

        if /usr/bin/test -e /etc/LCDd.conf ; then
            # Set the driver.
            /bin/sed -i "s%@MM_LCDPROC_DRIVER@%${MM_LCDPROC_DRIVER}%" /etc/LCDd.conf
            # Start LCDproc LCDd daemon and Myth LCD server.
            /usr/sbin/LCDd -c /etc/LCDd.conf
        fi
The sed output is not captured to a file nor is -d set for the LCDd command.

And to add further insult, for some reason the 0.20-2.31 is no longer taking my dhcp log-servers config; I had to add MM_LOG_SERVERS to the kernel parameters. I'm not sure why; it worked fine in 0.20-2.31b26.

rbroberts
Contributor
Posts: 61
Joined: Wed Nov 21, 2007 6:27 pm
Location: Brooklyn, NY
Contact:

Post by rbroberts » Wed Nov 28, 2007 4:49 am

Looking at this further, it would appear that the assumption is that if you are fetching the config, you don't really need to be substituting variables. So the quick fix for me was to hardcode "lis" as the driver in the config I download. Voile! it's working fine now.

Post Reply