smoothwall / atftp / minimyth.0.20.2-38 minimyth.conf not...

Help with booting MiniMyth

Moderator: Pablo

Post Reply
carpet_pants
New Member
Posts: 2
Joined: Sat Feb 23, 2008 3:15 pm

smoothwall / atftp / minimyth.0.20.2-38 minimyth.conf not...

Post by carpet_pants » Sat Feb 23, 2008 3:29 pm

Im trying to boot minimyth-0.20.2-38 using a neoware terminal. Im able to get a dhcp address from my smoothwall 3 (polar) box. I can successfully get the pxelinux ram boot image which is being served by atftp however I keep getting minimyth.conf not found. My config files are as follows:

> dhcp.conf

authoritative;
allow booting;
allow bootp;
next-server 10.0.0.1;
filename "pxelinux.0";
option root-path "10.0.0.1:/home/tftpboot";
ddns-update-style ad-hoc;

subnet 10.0.0.0 netmask 255.255.255.0
{
option subnet-mask 255.255.255.0;
option domain-name "";
option routers 10.0.0.1;
option domain-name-servers 10.0.0.1;
range dynamic-bootp 10.0.0.100 10.0.0.200;
default-lease-time 3600;
max-lease-time 7200;
}
subnet 10.0.1.0 netmask 255.255.255.0
{
option subnet-mask 255.255.255.0;
option domain-name "";
option routers 10.0.1.1;
option domain-name-servers 10.0.1.1;
range dynamic-bootp 10.0.1.90 10.0.1.99;
default-lease-time 3600;
max-lease-time 7200;
}


> pxelinux.cfg/default

##################################################################
# NETWORK BOOT CONFIG FILE (UDPCAST) #
##################################################################

display menu.txt
prompt 1
#KBDMAP french.kbd
TIMEOUT 200
default minimyth-ram

label minimyth-ram
kernel minimyth-0.20.2-38/kernel
append ro root=/dev/ram0 initrd=minimyth-0.20.2-38/rootfs ramdisk_size=64000 MM_DEBUG=yes MM_MINIMYTH_BOOT_URL="tftp://10.0.0.1/tftpboot"

Note: I have tried intially booting without the MM_MINIMYTH_BOOT_URL but it made no difference!



> conf/default/minimyth.conf

MM_MYTH_SERVER='10.0.0.240'
MM_MYTH_DBUSERNAME='mythtv'
MM_MYTH_DBPASSWORD='mythtv'
MM_MYTH_DBNAME='mythconverg'


Please help its driving me mad is this LOL. I use myth alot but this is my first time network booting, am I going wrong somewhere or?????

HELP

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Sat Feb 23, 2008 6:12 pm

First, when setting MM_MINIMYTH_BOOT_URL, it needs to contain a trailing slash (/).

Second, when setting MM_MINIMYTH_BOOT_URL, the path needs to be the path as seen by the specified protocol. In your case, based on the value of the DCHP filename option, the path should not contain 'tftproot'.

Those two things aside, there should be no need to set MM_MINIMYTH_BOOT_URL. Could you telnet into the frontend and provide the output of

/etc/conf.d/dhcp

and

/etc/hosts
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

carpet_pants
New Member
Posts: 2
Joined: Sat Feb 23, 2008 3:15 pm

SOLVED:

Post by carpet_pants » Sat Feb 23, 2008 8:55 pm

Ok its working now, not sure what I did but i now boots.

Sometimes the simplest things are required - I just stopped and restarted the atftp server but Im sure I had previously rebooted the smoothwall box.

Well sorry for wasting your time.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Sat Feb 23, 2008 10:03 pm

No problem.

I am glad that you got the gremlins out of the system and it is working.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply