Problem after linux boot.

Help with booting MiniMyth

Moderator: Pablo

Post Reply
grog
Member
Posts: 13
Joined: Sun Jun 25, 2006 5:34 am
Location: Brisbane, Australia

Problem after linux boot.

Post by grog » Wed Mar 12, 2008 1:36 am

I am having an interesting problem.

Linux seems to boot fine.
The configuration file seems to work fine.
X seems to start fine (i get the X mouse pointer on the screen)
But mythfrontend never seems to start.

I have looked through all the log files and i cant seem to actually find any errors, it just seems to start X then close X and say no more processes in this runlevel.



Last few lines of messgaes

Code: Select all

Mar 13 07:25:28 (none) local0.info minimyth: starting LCD/VFD ...
Mar 13 07:25:28 (none) local0.info minimyth: configuring MythTV ...
Mar 13 07:25:30 (none) local0.info minimyth: 'tftp://192.168.1.1/ram-minimyth-0.21.0-41/themes/G.A.N.T.sfs' downloaded.
Mar 13 07:25:31 (none) local0.info minimyth: 'tftp://192.168.1.1/ram-minimyth-0.21.0-41/themes/Titivillus-OSD.sfs' downloade
Mar 13 07:25:31 (none) local0.warn minimyth: warning: certain DVDs may not play. see <http://'MYTHFRONTEND'/minimyth/documen
Mar 13 07:25:32 (none) local0.info minimyth: updating fonts ...
Mar 13 07:25:32 (none) local0.info minimyth: configuring X ...
Mar 13 07:25:32 (none) local0.info minimyth: starting X ...
Mar 13 07:25:33 (none) local0.info minimyth: starting X
Mar 13 07:25:33 (none) auth.notice su: + none root:minimyth
Mar 13 07:25:33 (none) local0.info minimyth: stopping splash screen
Mar 12 20:25:33 (none) daemon.info init: no more processes left in this runlevel
Mar 13 07:25:33 (none) user.info kernel: agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
Mar 13 07:25:33 (none) user.info kernel: agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
Mar 13 07:25:33 (none) user.info kernel: agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
Mar 13 07:32:52 (none) auth.info login[8180]: root login on 'pts/0'
I do have this from minimyth.warn but i assumed it would be ok

Code: Select all

warning: 'ntpd' failed to synchronize with any NTP server.
Last fex lines of Xorg.0.0.log

Code: Select all

(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 9
(**) Mouse1: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) Keyboard1: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) XKB: disabled
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) evaluating device (Keyboard1)
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) evaluating device (Mouse1)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(**) Option "Device" "/dev/input/mice"
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/lib/X11/fonts/75dpi/, removing from list!
(II) CHROME(0): ViaTVPower: On.
(II) CHROME(0): VT1622Power
(II) CHROME(0): ViaTVPower: On.
(II) CHROME(0): VT1622Power
(II) CHROME(0): VIACloseScreen
(II) CHROME(0): [drm] Cleaning up DMA ring-buffer.
(II) CHROME(0): [drm] Freeing agp memory
(II) CHROME(0): [drm] Releasing agp module
(II) CHROME(0): [drm] removed 1 reserved context for kernel
(II) CHROME(0): [drm] unmapping 8192 bytes of SAREA 0xdcd28000 at 0xb3b0a000
(II) CHROME(0): [drm] Closed DRM master.
Freed 6638464 (pool 1)
(II) CHROME(0): [drm] Irq handler uninstalled.
(II) CHROME(0): VIARestore
(II) CHROME(0): VT162xRestore
(II) CHROME(0): ViaDisablePrimaryFIFO
(II) CHROME(0): VIAUnmapMem
FreeFontPath: FPE "/usr/lib/X11/fonts/misc" refcount is 2, should be 1; fixing.
~
and i have this in udhcpc

Code: Select all

udhcpc (v1.9.1) started
test: =: unknown operand
Sending discover...
Sending select for 192.168.1.201...
Lease of 192.168.1.201 obtained, lease time 43200
test: =: unknown operand

I'm at a loss of where to even start looking right now. Any help would be greatly appriciated.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed Mar 12, 2008 1:50 am

I suspect mythfrontend is crashing for some reason. If you telnet in as user 'minimyth' and run the command 'xinit', then do you see anything interesting?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

grog
Member
Posts: 13
Joined: Sun Jun 25, 2006 5:34 am
Location: Brisbane, Australia

Post by grog » Wed Mar 12, 2008 1:58 am

Ahh, yes, thank you very much.

Code: Select all

2008-03-13 07:55:27.574 Unexpected DB Schema version.  Waiting to see if DB is being upgraded.
2008-03-13 07:55:32.600 Timed out waiting.
2008-03-13 07:55:32.601 This version of MythTV requires an updated database schema. Please run mythtv-setup or mythbackend to update your database.
So it seems i will need to upgrade the backend for this version to work.


I hope there is an easy way of backing up the mythTV settings under mythbuntu, i really hate having to set everything up from scratch everytime i upgrade.

Thanks Pablo.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed Mar 12, 2008 2:08 am

grog wrote:Ahh, yes, thank you very much.

Code: Select all

2008-03-13 07:55:27.574 Unexpected DB Schema version.  Waiting to see if DB is being upgraded.
2008-03-13 07:55:32.600 Timed out waiting.
2008-03-13 07:55:32.601 This version of MythTV requires an updated database schema. Please run mythtv-setup or mythbackend to update your database.
So it seems i will need to upgrade the backend for this version to work.


I hope there is an easy way of backing up the mythTV settings under mythbuntu, i really hate having to set everything up from scratch everytime i upgrade.

Thanks Pablo.
If you do not want to upgrade to MythTV 0.21, the same version of MiniMyth is built with MythTV 0.20 as well. You can find it at latest-0.20.

If you decide to upgrade your backend to MythTV 0.21, be sure to back up your database first. The upgrade to MythTV 0.21 will upgrade the database schema.

Also, the /var/log/udhcpc log does show a minor bug that should be harmless. I have checked in a fix. Therefore, it will be fixed in the next build.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply