nfs-minimyth-0.20.2-41 & Kernel panic not syncing

Help with booting MiniMyth

Moderator: Pablo

Post Reply
MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

nfs-minimyth-0.20.2-41 & Kernel panic not syncing

Post by MythLegend » Thu Mar 13, 2008 3:35 pm

Hi,
Trying to speed up boot process, have until recently been using PXELINUX and ram-minimyth, got the gPXE working and have been trying since to get PXELINUX and nfs-minimyth-0.20.2-41 working, having a few problems, initially don't think my directory structure was very similar to the 'standard', hopefully now it is better, but not getting very far in the boot process.

What I have:
tvserver 192.168.0.220
myth1 192.168.0.221

on tvserver, I am exporting NFS filesystem
/tftpboot/minimyth 192.168.0.1/255.255.255.0(rw)

my /etc/dhcp3/dhcpd.conf on tvserver contains :
filename "/minimyth/pxelinux.0";

/tftpboot/minimyth/pxelinux.cfg contains

DEFAULT mythnfs
LABEL mythnfs
KERNEL minimyth-0.20.2-41/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.0.220:/tftpboot/minimyth/minimyth-0.20.2-41

I have followed the instructions
http://linpvr.org/minimyth/document-boo ... elinux-nfs
under "Network Boot using PXELINUX with an NFS Root File System"
only thing is that I do not have a separate NFS directory, I am sharing the /tftpboot/minimyth directory itself - don't think that this should be a problem?

Looked at pxe-minimyth-0.20.2-41.tar.bz2, which has a pxelinux.cfg/default containing:

DEFAULT minimyth-ram

LABEL minimyth-ram
KERNEL minimyth-minimyth-0.20.2-41/kernel
APPEND ro root=/dev/ram0 ramdisk_size=96000 initrd=minimyth-minimyth-0.20.2-41/rootfs

LABEL minimyth-nfs
KERNEL minimyth-minimyth-0.20.2-41/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.0.1:/home/public/minimyth/minimyth-minimyth-0.20.2-41

but wondering if the KERNEL line with minimyth-minimyth, if the hyphen is a typo and should be a '/' in which case my directory structure is still wrong, anyway, going round in circles a bit, so any help would be appreciated.

Thanks.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: nfs-minimyth-0.20.2-41 & Kernel panic not syncing

Post by Pablo » Thu Mar 13, 2008 5:20 pm

MythLegend wrote:Hi,
Trying to speed up boot process, have until recently been using PXELINUX and ram-minimyth, got the gPXE working and have been trying since to get PXELINUX and nfs-minimyth-0.20.2-41 working, having a few problems, initially don't think my directory structure was very similar to the 'standard', hopefully now it is better, but not getting very far in the boot process.

What I have:
tvserver 192.168.0.220
myth1 192.168.0.221

on tvserver, I am exporting NFS filesystem
/tftpboot/minimyth 192.168.0.1/255.255.255.0(rw)

my /etc/dhcp3/dhcpd.conf on tvserver contains :
filename "/minimyth/pxelinux.0";

/tftpboot/minimyth/pxelinux.cfg contains

DEFAULT mythnfs
LABEL mythnfs
KERNEL minimyth-0.20.2-41/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.0.220:/tftpboot/minimyth/minimyth-0.20.2-41

I have followed the instructions
http://linpvr.org/minimyth/document-boo ... elinux-nfs
under "Network Boot using PXELINUX with an NFS Root File System"
only thing is that I do not have a separate NFS directory, I am sharing the /tftpboot/minimyth directory itself - don't think that this should be a problem?
What is the directory listing of '/tftpboot/minimyth/minimyth-0.20.2-41'? Does it contain, the expansion of nfs-minimyth-0.20.2-41.tar.bz2? Was the expansion done as root?
Looked at pxe-minimyth-0.20.2-41.tar.bz2, which has a pxelinux.cfg/default containing:

DEFAULT minimyth-ram

LABEL minimyth-ram
KERNEL minimyth-minimyth-0.20.2-41/kernel
APPEND ro root=/dev/ram0 ramdisk_size=96000 initrd=minimyth-minimyth-0.20.2-41/rootfs

LABEL minimyth-nfs
KERNEL minimyth-minimyth-0.20.2-41/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.0.1:/home/public/minimyth/minimyth-minimyth-0.20.2-41

but wondering if the KERNEL line with minimyth-minimyth, if the hyphen is a typo and should be a '/' in which case my directory structure is still wrong, anyway, going round in circles a bit, so any help would be appreciated.
That is a typo. There should be no 'minimyth-'. I will fix it.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Thu Mar 13, 2008 5:30 pm

Hi,

Yes, everything was expanded as root, the directory listing is

root@tvserver:/tftpboot/minimyth# ls -alrt minimyth-0.20.2-41

total 1404
drwxr-xr-x 2 root root 4096 2008-03-10 18:30 sbin
drwxr-xr-x 2 root root 4096 2008-03-10 18:30 rw
drwxr-xr-x 2 root root 4096 2008-03-10 18:30 rootfs
drwxr-xr-x 2 root root 4096 2008-03-10 18:30 bin
drwxr-xr-x 11 root root 4096 2008-03-10 18:30 rootfs-ro
drwxrwxr-x 26 root root 4096 2008-03-13 13:34 ..
-rw-r--r-- 1 root root 1401240 2008-03-13 13:35 kernel
lrwxrwxrwx 1 root root 13 2008-03-13 13:57 lib -> rootfs-ro/lib
lrwxrwxrwx 1 root root 13 2008-03-13 13:57 dev -> rootfs-ro/dev
drwxr-xr-x 7 root root 4096 2008-03-13 13:58 .

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Thu Mar 13, 2008 5:51 pm

If you use a separate directory for the NFS share, does it work?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Thu Mar 13, 2008 6:41 pm

Hi,

have created a directory /tftpboot/nfs and copied the minimyth-0.20.2-41 directory from /tftpboot/minimyth into it, added this new nfs directory to the /etc/exports file:

/tftpboot/minimyth 192.168.0.1/255.255.255.0(rw)
/tftpboot/nfs 192.168.0.1/255.255.255.0(rw)

changed the file in pxelinux.cfg to:

LABEL mythnfs
KERNEL minimyth-0.20.2-41/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.0.220:/tftpboot/nfs/minimyth-0.20.2-41

unfortunately still get the kernel panic.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Thu Mar 13, 2008 6:58 pm

think that the /etc/exports was wrong, so changed it to:

/tftpboot/nfs/minimyth-0.20.2-41 192.168.0.1/255.255.255.0(rw)

made no difference.

tsjoender
Contributor
Posts: 87
Joined: Mon Nov 05, 2007 9:45 am
Location: Friesland, The Netherlands

Post by tsjoender » Fri Mar 14, 2008 9:45 am

Do you see error messages in /var/log/messages on the server hosting the NFS share? Do you have another Linux box that can mount the NFS share?

I would first try to make sure the NFS share is exported correctly. Using another Linux box (you could even try mounting the NFS share on the same box that is hosting it).

BTW in you first post you say that you have a box with IP 192.168.0.220 exporting the NFS share. The second box (minimyth I presume) is assigned 192.168.0.221. Further on I see al kinds of references to IP 192.168.0.1 (for both the server where the NFS share is hosted and the host allowed to mount the NFS share. Perhaps you can change the line in /etc/exports to read:

Code: Select all

/tftpboot/nfs/minimyth-0.20.2-41 192.168.0.0/255.255.255.0(rw)
This way you allow all 192.168.0.x IP addresses rw access to this share. May not be what you want now, but might help testing things. Later you can change the IP access settings again.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Fri Mar 14, 2008 4:01 pm

Hi tsjoender,

Well spotted on the nfs ip error, however it was allowing me to mount on any PC in the 192.168.0.* subnet, I have now changed it to 192.168.0.0 and have reconfirmed that I am able to mount it on another PC (see last line of log below).

There are no errors in /var/log/messages and this is the output of /var/log/syslog, where I power on the myth client 192.168.0.221 and the last line is another PC doing the mount nfs check.

Mar 14 12:25:14 tvserver dhcpd: DHCPDISCOVER from 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:14 tvserver dhcpd: DHCPOFFER on 192.168.0.221 to 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:16 tvserver dhcpd: DHCPREQUEST for 192.168.0.221 (192.168.0.220) from 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:16 tvserver dhcpd: DHCPACK on 192.168.0.221 to 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:16 tvserver atftpd[5190]: Serving /minimyth/pxelinux.0 to 192.168.0.221:2070
Mar 14 12:25:16 tvserver atftpd[5190]: Serving /minimyth/pxelinux.0 to 192.168.0.221:2071
Mar 14 12:25:16 tvserver atftpd[5190]: Serving /minimyth/pxelinux.cfg/01-00-40-63-e6-2a-27 to 192.168.0.221:57089
Mar 14 12:25:17 tvserver atftpd[5190]: Serving /minimyth/minimyth-0.20.2-41/kernel to 192.168.0.221:57090
Mar 14 12:25:21 tvserver dhcpd: DHCPDISCOVER from 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:21 tvserver dhcpd: DHCPOFFER on 192.168.0.221 to 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:21 tvserver dhcpd: DHCPREQUEST for 192.168.0.221 (192.168.0.220) from 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:21 tvserver dhcpd: DHCPACK on 192.168.0.221 to 00:40:63:e6:2a:27 via eth1
Mar 14 12:25:26 tvserver mountd[5324]: authenticated mount request from 192.168.0.221:766 for /tftpboot/nfs/minimyth-0.20.2-41 (/tftpboot/nfs/minimyth-0.20.2-41)
Mar 14 12:25:31 tvserver mountd[5324]: authenticated mount request from 192.168.0.221:766 for /tftpboot/nfs/minimyth-0.20.2-41 (/tftpboot/nfs/minimyth-0.20.2-41)
Mar 14 12:27:55 tvserver mountd[5324]: authenticated mount request from quark.local:758 for /tftpboot/nfs/minimyth-0.20.2-41 (/tftpboot/nfs/minimyth-0.20.2-41)

Not sure why there are two mount requests for the nfs directory ?



Also, proved that I can do this nfs mount from the minimyth client (when booted using ram-minimyth-0.20.2-41:

myth1 login: root
BusyBox v1.9.1 (2008-03-10 00:19:17 PDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

root@myth1:~ # mkdir /tmp/xx
root@myth1:~ # cd /tmp
root@myth1:/tmp # mount -t nfs 192.168.0.220:/tftpboot/nfs/minimyth-0.20.2-41 ./xx
mount.nfs: rpc.statd is not running but is required for remote locking
Either use "-o nolock" to keep locks local, or start statd.
root@myth1:/tmp # mount -t nfs -o nolock 192.168.0.220:/tftpboot/nfs/minimyth-0.20.2-41 ./xx
root@myth1:/tmp # ls -alrt xx
drwxr-xr-x 2 root root 4096 Mar 10 18:30 sbin
drwxr-xr-x 2 root root 4096 Mar 10 18:30 rw
drwxr-xr-x 2 root root 4096 Mar 10 18:30 rootfs
drwxr-xr-x 2 root root 4096 Mar 10 18:30 bin
drwxr-xr-x 11 root root 4096 Mar 10 18:30 rootfs-ro
lrwxrwxrwx 1 root root 13 Mar 13 17:49 lib -> rootfs-ro/lib
lrwxrwxrwx 1 root root 13 Mar 13 17:49 dev -> rootfs-ro/dev
drwxr-xr-x 7 root root 4096 Mar 13 17:49 .
drwxrwxrwt 4 root root 120 Mar 14 14:45 ..
root@myth1:/tmp #

so, the nfs export is definitely working.

I have just downloaded the 0.20.2-42 and will try it again from scratch.

Thanks

Post Reply