Page 1 of 1

Stops during boot without error message

Posted: Sun Mar 23, 2008 1:19 am
by zond
I am trying to run MiniMyth on my VIA EPIA EX 10000 EG motherboard.

It starts fine, loads kernel and mounts root over nfs, detects keyboard and mouse and loads the config file (which looks like:

MM_X_ENABLED='no'
MM_X_OUTPUT_VGA='auto'
MM_DHCP_HOST_NAME='swallow'
MM_DHCP_TCODE='Europe/Stockholm'
MM_DHCP_NTP_SERVERS='0.debian.pool.ntp.org'
MM_THEME_NAME='default'
MM_THEMEOSD_NAME='defaultosd'
MM_SSH_SERVER_ENABLED='yes'
MM_DEBUG='yes'

), but then everything just stops. I can type with my keyboard and the characters show up on the screen, but there is no prompt or anything, and no error messages.

Does anyone have any ideas why this happens?

regards,
//Martin Kihlgren

Posted: Sun Mar 23, 2008 3:07 am
by Pablo
Since it fetches the minimyth.conf file, you should be able to telnet (unless it is failing when it restarts the DHCP client after fetching the minimyth.conf). If you can telnet in, then you can check /var/log/* for any logs.

For MM_DEBUG to work completely, it needs to be on the boot line (MM_DEBUG="yes").

If you provide an empty minimyth.conf, does it get further?

Posted: Mon Mar 31, 2008 1:44 pm
by zond
Right, I will try to telnet in and see if I can see any log files.

When I tried with an empty minimyt.conf, it stops and provides a shell, and I can see the errors in a log file.

On the boot line I have added just a "debug", which seems to do the trick as well (and should, according to the docu, IIRC).

Thanks for the hint about telneting, I will try it and get back :)

regards,
//Martin

[solved] Stops during boot without error message

Posted: Sat May 03, 2008 1:39 pm
by zond
Ah, the problem was that when debug and MM_DEBUG was enabled, I didnt see a lot of the error messages.

It seems to actually start loading fine, and if I wait _forever_ it actually starts the telnet server. I will post a new topic about that though.

//Martin