Page 1 of 1

Kernel panic in unionfs

Posted: Sun Apr 13, 2008 9:12 pm
by kdewaal

After upgrading to Myth 0.21 I have lots of kernel panics.
The panic happens when the display shows:
loading kernel modules (automatic) ...
The panic does not happen all of the time, sometimes the boot goes OK without panic. Sometimes the system hangs in the "loading kernel modules" message and sometimes the boot continues until completion into a working system.
The panic does depend on the MiniMyth/MythTV version:
21.0-43 panic (most of the time)
21.0-44 OK (always boot OK, no panic)
21.0-47 panic (most of the time)

This is the "dmesg" output after a completed boot of the 21.0-47:
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
BUG: unable to handle kernel paging request at virtual address 766972b4
printing eip: f8837055 *pde = 00000000
Oops: 0000 [#1] SMP
Modules linked in: ohci_hcd ehci_hcd k8temp snd libata psmouse evdev hwmon ieee1
394 soundcore scsi_mod i2c_nforce2 nvidia(P) agpgart i2c_core fan thermal button
processor ppdev parport_pc parport loop as_iosched rtc af_packet usbcore unionf

Pid: 1628, comm: modprobe Tainted: P ( #1)
EIP: 0060:[<f8837055>] EFLAGS: 00010202 CPU: 0
EIP is at unionfs_copy_attr_times+0x27/0x86 [unionfs]
EAX: f7557480 EBX: f74e7f30 ECX: 76697264 EDX: f7930624
ESI: 00000000 EDI: 00000000 EBP: f79305f8 ESP: f74e7d88
DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 1628, ti=f74e6000 task=f7549030 task.ti=f74e6000)
Stack: f74e7f30 f78c9494 f7c0dec0 00000000 f88393d8 f78c8794 f8845d6c f78c9494
f7930624 f7930694 c01655d5 f74e7e0c f74e7e00 f74e7f30 f7c0dec0 f74e7f30
f745c029 f7930624 f7806894 c0166bcf f745c034 00000101 00000000 00000000
Call Trace:
[<f88393d8>] unionfs_lookup+0x9c/0xe9 [unionfs]
[<c01655d5>] do_lookup+0xa1/0x140
[<c0166bcf>] __link_path_walk+0x77b/0xb48
[<c0166feb>] link_path_walk+0x4f/0xc5
[<f8840ab2>] unionfs_file_release+0x1b7/0x1c5 [unionfs]
[<c015dc84>] get_unused_fd_flags+0x58/0xb8
[<c016744e>] do_path_lookup+0x16b/0x186
[<c01602b3>] get_empty_filp+0x8a/0x11d
[<c01676b4>] __path_lookup_intent_open+0x48/0x77
[<c0167703>] path_lookup_open+0x20/0x25
[<c0167eb7>] open_namei+0x6f/0x538
[<c016dfe9>] dput+0x22/0xf4
[<c015df09>] do_filp_open+0x2a/0x3e
[<f8840ab2>] unionfs_file_release+0x1b7/0x1c5 [unionfs]
[<c015dc84>] get_unused_fd_flags+0x58/0xb8
[<c015df61>] do_sys_open+0x44/0xcf
[<c015db96>] filp_close+0x51/0x58
[<c015e025>] sys_open+0x1c/0x1e
[<c0103eb2>] syscall_call+0x7/0xb
Code: 28 89 d0 c3 55 89 c2 57 85 c0 56 53 74 77 8b 70 d4 8d 68 d4 85 f6 8d 3c b5
00 00 00 00 79 61 eb 64 8b 45 28 8b 0c 38 85 c9 74 51 <8b> 59 50 39 5a 50 7c 0a
7f 11 8b 41 54 39 42 54 79 09 8b 41 54
EIP: [<f8837055>] unionfs_copy_attr_times+0x27/0x86 [unionfs] SS:ESP 0068:f74e7d
---[ end trace 7c9a3b358802de8c ]---
ACPI: PCI Interrupt Link [APCF] enabled at IRQ 21
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [APCF] -> GSI 21 (level, low) -> IRQ
PCI: Setting latency timer of device 0000:00:0b.0 to 64
ohci_hcd 0000:00:0b.0: OHCI Host Controller
ohci_hcd 0000:00:0b.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:0b.0: irq 19, io mem 0xfe02f000
unionfs: new lower inode mtime (bindex=0, name=host)

The MythTV-frontend is an Asus M2NPV-VM motherboard with integrated Nvidia 6150 graphics, an AM2 socket with a AMD3500 CPU and 1GB dual-channel DDR2-533 memory, and with an MCE USB remote control.
All hardware (except the MCE remote which was bought recently) worked OK in minimyth-0.20.2-34 and has not been changed.

Anybody any ideas?


Posted: Sun Apr 13, 2008 10:50 pm
by Pablo
Strange. I have the same motherboard and I am using and MCE remote.

What MiniMyth version were you running before?

What BIOS version are you using (I am using 1001)?

Posted: Mon Apr 14, 2008 7:30 pm
by kdewaal
BIOS version was 801. I have upgraded just now to 1301 (latest&greatest) and tested again but this does not change anything; panics still come about half of the time, the other half the boot is just OK.
I have not seen this problem on any of the 0.20 versions of MiniMyth, the last 0.20 version before switching to 0.21 is the 0.20.2-34.
Panics also happen with the LIRC infrared serial driver remote instead of the MCE.
System runs on NFS, kernel loaded via tftpboot (don't know if this matters).
N.B. the 0.21.0-44 version does NOT have the problem.
Hope this is useful,

Posted: Mon Apr 14, 2008 7:39 pm
by Pablo
Thank you for the information.

-44 uses the same version of unionfs but uses a newer kernel (2.6.25-rc6). I reverted to the older kernel ( because 2.6.25-rc6 broke ACPI. However, this is supposed to have been fixed it in 2.6.25-rc8. I will build MiniMyth with 2.6.25-rc9. If ACPI works on my VIA EPIA SP8000E, then I will upload a test version.

Posted: Mon Apr 14, 2008 8:28 pm
by mx-5
Gotta say that I should have posted something when I saw this myself.

I have a i815 based motherboard and saw a few kernel panic on 0.20.2-43 (i think?) I never even caught where this panic came - I doubt there was enough time for the tftp to complete though. I thought it might be my flakier older hardware, but after upgrading to 0.20.2-46 (newest at the time), I haven't seen the error for the past week.

Posted: Tue Apr 15, 2008 5:06 am
by Pablo
Unfortunately, it does not appear that we can switch to kernel 2.6.25 at this point. Kernel 2.6.25-rc9 oops with unionfs 2.2.4. However, unionfs 2.3.2 is broken, failing to append the first string echo-ed to an existing file on the underlying read-only file.

I suppose we could try rolling back to 2.6.23. I will built 2.6.23 and see whether or not I encounter any problems.

Posted: Fri Apr 18, 2008 5:28 pm
by Pablo
Well, I posted my problem with unionfs and kernel 2.6.25 to the unionfs mailing list and they quickly provided a fix. Therefore, I have uploaded a test version of MiniMyth (-48b1) that contains the released 2.6.25 kernel and a patched version of unionfs 2.3.2. Could you test whether or not it solves your problem.

Posted: Fri Apr 18, 2008 10:00 pm
by kdewaal
OK, problem solved!
With the 48b1 it boots everytime without problems.

Many thanks,

Posted: Wed May 07, 2008 4:14 am
by Pablo
If you have a chance, could you give -49 a try.

It has the kernel patched with the 2.3.3 unionfs. Others have been getting kernel oops with the 2.6.25 kernel. Hopefully, it is the newer unionfs and not the newer kernel that fixed your problem.

Kernel panic in unionfs

Posted: Wed May 07, 2008 11:22 am
by m_theredhead
Pablo wrote:If you have a chance, could you give -49 a try.

It has the kernel patched with the 2.3.3 unionfs. Others have been getting kernel oops with the 2.6.25 kernel. Hopefully, it is the newer unionfs and not the newer kernel that fixed your problem.
-49 is working for me. -48 panic'ed with the unionfs issue.