Anybody successfully running an EPIA-EN board??

Help with booting MiniMyth

Moderator: Pablo

Post Reply
BobLHead
Member
Posts: 11
Joined: Mon May 19, 2008 7:06 am

Anybody successfully running an EPIA-EN board??

Post by BobLHead » Tue May 20, 2008 8:39 pm

I'm not able to get X to configure properly. I'm thinking this is just another case of don't buy EPIA.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Post by lofty69 » Wed May 21, 2008 9:44 am

yes, been running minimyth on mine for a while now.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed May 21, 2008 5:35 pm

This board drives the television outputs with the VT1625M HDTV encoder. Sadly, the support for this chip in the openchrome driver is rather limited. Whether or not it works appears to depend on the resolution and output chosen (no, I do not know what combinations work).

Of course, those using the VGA output bypass VT1625M. Therefore, they will likely have no problems with X.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

BobLHead
Member
Posts: 11
Joined: Mon May 19, 2008 7:06 am

Yeah, but are you using TV out?

Post by BobLHead » Thu May 22, 2008 1:57 am

yes, been running minimyth on mine for a while now.
Are you using TV out, if so, how do you have X configured?

BobLHead
Member
Posts: 11
Joined: Mon May 19, 2008 7:06 am

OpenChrome won't work. Let's talk Unichrome

Post by BobLHead » Thu May 22, 2008 2:04 am

Pablo wrote:Whether or not it works appears to depend on the resolution and output chosen (no, I do not know what combinations work).
In openchrome, there's only 4: 720x480Over, 720x480Under, 720x480Fit, 640x480. They all look different, and they all fail. You're also not allowed to use custom modelines. Seems pretty clear I need to get a new monitor or I need to try the Unichrome drivers which have their own set of drawbacks.

I notice the unichrome drivers aren't included in minimyth. Any quick way to add them without having to get into the build environment? From what I can tell, the unichrome drivers aren't built, anyway. They're distributed in binary form.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Thu May 22, 2008 3:00 am

You can add a custom modeline using MM_X_MODELINE.

It is my understanding that XvMC-VLD support was removed from the unichrome drivers until all the mode setting and functional partitioning was cleaned up.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

BobLHead
Member
Posts: 11
Joined: Mon May 19, 2008 7:06 am

It's the driver

Post by BobLHead » Sat May 24, 2008 4:58 pm

Pablo wrote:You can add a custom modeline using MM_X_MODELINE.
It's not minimyth that's the problem. It's the openchrome drivers. The openchrome drivers validate any custom modelines. That's "validate" - pronounced reject - so it's openchrome's modes or the highway.

lofty69
Contributor
Posts: 168
Joined: Fri Mar 02, 2007 5:46 pm
Location: Watching Mythtv via Minimyth

Re: Yeah, but are you using TV out?

Post by lofty69 » Sat May 24, 2008 6:51 pm

BobLHead wrote:
yes, been running minimyth on mine for a while now.
Are you using TV out, if so, how do you have X configured?
running over vga to an lcd.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Sat May 24, 2008 8:01 pm

If you are using VGA, then you should be able to use standard resolutions.

Have you tried

Code: Select all

MM_X_OUTPUT_VGA='auto'
MM_X_RESOLUTION="1024x768"
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply