Page 1 of 1

Problem booting when MM_MEDIA_DVD is set

Posted: Wed Oct 01, 2008 9:04 am
by pleeke
Pablo,


I've noticed an issue when booting minimyth r3973 (the same exact config works in minimyth58b3). If I set;
MM_MEDIA_DVD_RIP_MOUNTPOINT='/data/tmp'
MM_MEDIA_DVD_RIP_URL=nfs://192.168.0.10/data/tmp
Then i get this error when booting;
error: 'mtd' not found.

I don't have MM_INIT_TYPE set on the boot line, so assume I'm using the 'sh' based boot scripts still.

Removing the two MM_MEDIA_DVD lines from minimyth.conf and it all boots fine. Not a real problem as I no longer use the frontend to rip dvds, but thought I'd mention it.


Thanks
Peter

Posted: Wed Oct 08, 2008 7:50 pm
by Pablo
Thanks.

As there is no r3973 yet, I assume you are using r3793. If this is the case, then the init scripts are defaulting to perl rather than sh.

I am able to reproduce the problem using the perl init scripts. There is a bug in mythtv.pm (not to mention MiniMyth.pm). I will include the fixes in the next test build (59b4).

Posted: Sat Oct 11, 2008 4:22 pm
by Pablo
This should be fixed in 59b4. Could you let me know whether or not it works for you?

Posted: Fri Oct 17, 2008 10:26 am
by pleeke
Pablo,

Yes 59b5 works fine when booting with perl & setting the DVD_RIP options in minimyth.conf.

Have noticed an issue though, with a perl boot my lcd display is not detected/ lcdproc is not started. With a 'sh' boot using same minimyth s/w version (59b5) & minimyth cfg it works ok. I'll look into this over the next few days to see if I can figure out whats going on.


Thanks
Peter

Posted: Fri Oct 17, 2008 10:46 pm
by Pablo
pleeke wrote:Have noticed an issue though, with a perl boot my lcd display is not detected/ lcdproc is not started. With a 'sh' boot using same minimyth s/w version (59b5) & minimyth cfg it works ok. I'll look into this over the next few days to see if I can figure out whats going on.
That would be a bug resulting from a cut-and-paste error. I have made the change and it will be in the next test build (59b6). As I do not have an LCD device, I cannot test it.