Page 1 of 1

warning: 'ntpd' failed to synchronize with any NTP server.

Posted: Wed Nov 05, 2008 10:20 pm
by bowlby
Hi,
I'm trying to upgrade my setup to 21 and running into trouble. The boot proces can't seem to sync with a NTP server and stops displaying:
warning: 'ntpd' failed to synchronize with any NTP server
Any suggestions?

I'm using:
ram-minimyth-0.21.0-59

And this is my minimyth.conf:

Code: Select all

MM_DHCP_TCODE = 'Europe/Amsterdam'
MM_DEBUG = 'YES'
MM_DHCP_NTP_SERVERS = '0.nl.pool.ntp.org'
MM_NTP_FAILURE_ACTION='continue'
MM_THEME_NAME='MythCenter'
MM_THEMEOSD_NAME='Titivillus-OSD'

MM_X_OUTPUT_VGA='auto'
MM_X_OUTPUT_TV='auto'
MM_X_TV_TYPE='PAL'
MM_X_TV_OUTPUT='S-Video'

MM_MASTER_SERVER='192.168.1.26'
MM_MASTER_DBUSERNAME='mythtv'
MM_MASTER_DBPASSWORD='xxxxxxx'
MM_MASTER_DBNAME='mythconverg'
The log-file shows:

Code: Select all

Nov  6 04:59:59 (none) local0.info minimyth: configuring ssh server ...
Nov  6 04:59:59 (none) user.info kernel: unionfs: new lower inode mtime (bindex=0, name=ssh)
Nov  6 04:59:59 (none) local0.info minimyth: starting cron ...
Nov  6 04:59:59 (none) local0.info minimyth: configuring MythTV master backend communication ...
Nov  6 04:59:59 (none) local0.info minimyth: installing binary codecs ...
Nov  6 05:00:00 (none) local0.info minimyth: installing extras ...
Nov  6 05:00:00 (none) local0.info minimyth: checking sensors ...
Nov  6 05:00:00 (none) local0.info minimyth: starting ACPI ...
Nov  6 05:00:00 (none) daemon.info acpid: starting up
Nov  6 05:00:00 (none) daemon.info acpid: 1 rule loaded
Nov  6 05:00:00 (none) daemon.info acpid: waiting for events: event logging is off
Nov  6 05:00:01 (none) local0.info minimyth: setting time ...
Nov  6 05:00:01 (none) local0.warn minimyth: warning: 'ntpd' failed to synchronize with any NTP server.
Nov  6 05:00:01 (none) local0.info minimyth: starting NTP daemon ...
Nov  6 05:00:01 (none) daemon.notice ntpd[2271]: ntpd 4.2.4p5@1.1541 Sat Nov  1 09:04:41 UTC 2008 (1)
Nov  6 05:00:01 (none) daemon.info ntpd[2272]: precision = 1.000 usec
Nov  6 05:00:01 (none) daemon.debug ntpd[2272]: ntp_io: estimated max descriptors: 1024, initial socket boundary: 16
Nov  6 05:00:01 (none) daemon.info ntpd[2272]: Listening on interface #0 wildcard, 0.0.0.0#123 Disabled
Nov  6 05:00:01 (none) daemon.info ntpd[2272]: Listening on interface #1 lo, 127.0.0.1#123 Enabled
Nov  6 05:00:01 (none) daemon.info ntpd[2272]: Listening on interface #2 eth0, 192.168.1.40#123 Enabled
Nov  6 05:00:01 (none) daemon.info ntpd[2272]: kernel time sync status 0040
Nov  6 05:00:01 (none) local0.info minimyth: starting web server ...
Nov  6 05:00:02 (none) daemon.notice webfsd[2281]: started (listen on *:80, root=/srv/www, user=httpd, group=httpd)
Nov  6 05:00:02 (none) daemon.notice webfsd[2283]: started (listen on *:8080, root=/, user=root, group=root)
Nov  6 05:00:02 (none) local0.info minimyth: mounting media shares ...
Nov  6 05:00:02 (none) local0.info minimyth: configuring audio ...
Nov  6 05:00:03 (none) local0.info minimyth: configuring video ...
Nov  6 05:00:03 (none) daemon.info init: no more processes left in this runlevel
Nov  6 05:11:06 (none) auth.info login[2332]: root login on 'pts/0'
Nov  6 05:12:30 (none) user.info kernel: unionfs: new lower inode mtime (bindex=0, name=src)
[/quote][/code]

Re: warning: 'ntpd' failed to synchronize with any NTP serve

Posted: Wed Nov 05, 2008 11:08 pm
by Pablo
bowlby wrote:

Code: Select all

MM_DHCP_TCODE = 'Europe/Amsterdam'
MM_DEBUG = 'YES'
MM_DHCP_NTP_SERVERS = '0.nl.pool.ntp.org'
MM_NTP_FAILURE_ACTION='continue'
MM_THEME_NAME='MythCenter'
MM_THEMEOSD_NAME='Titivillus-OSD'

MM_X_OUTPUT_VGA='auto'
MM_X_OUTPUT_TV='auto'
MM_X_TV_TYPE='PAL'
MM_X_TV_OUTPUT='S-Video'

MM_MASTER_SERVER='192.168.1.26'
MM_MASTER_DBUSERNAME='mythtv'
MM_MASTER_DBPASSWORD='xxxxxxx'
MM_MASTER_DBNAME='mythconverg'
Is this an exact copy of you minimyth.conf? The reason that I ask is that MM_DHCP_TCODE, MM_DEBUG and MM_DHCP_NTP_SERVERS have spaces before and after the =, which would cause them to have no value set.

Posted: Thu Nov 06, 2008 10:41 am
by bowlby
Hi Pablo,

I removed the spaces (and the line with MM_DEBUG) but still no luck. Ik keep getting the same error.

Posted: Thu Nov 06, 2008 6:34 pm
by osy
I got similar error message with ram-minimyth-0.20.2-59. It went away when I changed the NTP server's hostname to the corresponding numeric ip address. It had worked fine earlier with the hostname. I have not dug any deeper for the reason, though.

Posted: Thu Nov 06, 2008 7:06 pm
by Pablo
I believe that I have tracked down the problem. The hostname/ip being passed to ntpdate had a new-line at the end. When is was a hostname, ntpdate passed the hostname including the new-line to the resolver and the resolver could not resolve it because of the trailing new-line.

The fix will be in the next test build (60b3).

Posted: Thu Nov 06, 2008 8:36 pm
by bowlby
Is there a way to bypass this problem?
(We where in the middle of a 24- serie, the suspense is killing us...)

Posted: Thu Nov 06, 2008 8:45 pm
by osy
It should work right away if you change
MM_DHCP_NTP_SERVERS='0.nl.pool.ntp.org'
to
MM_DHCP_NTP_SERVERS='213.239.154.12'
which is the ip address for the NTP server you have been using.

You get the ip by pinging the server with its hostname:
ping 0.nl.pool.ntp.org

Posted: Thu Nov 06, 2008 9:45 pm
by bowlby
Thanks! That fixed the ntp-error!

Posted: Fri Nov 07, 2008 3:01 pm
by Pablo
The latest test build (60b3) should fix the problem with using a name rather than an IP address for the NTP server.