Page 1 of 1

Routing/DHCP - Accessing BE on another subnet not working.

Posted: Sun Dec 28, 2008 6:50 am
by sirlach
Hello,

I have been testing my front ends for about a month now and had finally got to a point where I can deploy them. In testing the FE and BE were on the same network but in production they are on separate subnets.

When I boot the FE they get to talking to the back end and stops with the unable to talk to backend error.

The FE's are on a 192.168.1.0 network. The Backend is on a 192.168.20.0 network. DHCP and Routing with Linux/Windows hosts works fine between the 2 networks. When I telnet into the FE and run route I only get 1 line - see below -

Code: Select all

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
DHCP has been fully configured.

It appears that the DHCP IP config is being rewritten and losing the default gateway.

I am running PXE Boot with the ram-minimyth-0.21.0-62 image.

I have had a poke around the udhcpc script as was pointed out in a previous post but not being a scripting guru I can't figure out which part of the script is killing the IP config.

Any help greatly appreciated.

Posted: Sun Dec 28, 2008 5:29 pm
by Pablo
Could you provide your DHCP configuration file?

Posted: Mon Dec 29, 2008 1:26 am
by sirlach
Here you go.

The host pygmy is the FE.

Code: Select all

ddns-update-style none;

default-lease-time 600;
max-lease-time 7200;
option tcode code 101 = text;
log-facility local7;

# Puddies.local
subnet 192.168.20.0 netmask 255.255.255.0 {
	option domain-name "puddies.local";
	option ntp-servers ntp.internode.on.net;
	option domain-name-servers 192.168.20.2 , 192.168.20.1;
	option subnet-mask 255.255.255.0;
	option time-servers ntp.internode.on.net;
	option routers 192.168.20.1;
	authoritative;
	allow client-updates;
	ddns-updates on;
	range 192.168.20.128 192.168.20.254;
	}

# wildpossum.com
subnet 192.168.1.0 netmask 255.255.255.0 {
	option broadcast-address 192.168.1.255;
        option ntp-servers ntp.iinet.com.au;
	option time-servers ntp.iinet.com.au;
	option subnet-mask 255.255.255.0;
	option domain-name-servers 192.168.1.1;
	option routers 192.168.1.1;
	authoritative;
	range dynamic-bootp 192.168.1.128 192.168.1.254;
	allow client-updates;
	ddns-updates on;
	# pygmy
	host pygmy {
		option log-servers 192.168.1.41;
		option domain-name "wildpossum.com";
		filename "PXEClient/pxelinux.0";
		option ntp-servers ntp.iinet.com.au;
		option time-servers ntp.iinet.com.au;
		option domain-name-servers 192.168.1.1;
		option subnet-mask 255.255.255.0;
		option routers 192.168.20.1;
		option host-name "pygmy";
		option tcode "Australia/Sydney";
		hardware ethernet 00:30:18:a0:bb:e1;
		fixed-address 192.168.1.120;
		}
	}

Posted: Mon Dec 29, 2008 3:47 am
by Pablo
According to the DHCP Options RFC, routers must be on the client's subnet but 192.168.20.1 is not on the 192.168.1.120/255.255.255.0 subnet.

Posted: Mon Dec 29, 2008 12:06 pm
by sirlach
(Sound of keyboard striking head a couple of times. )

:oops:

Thanks.