Module coretemp is not loaded automatically

Help with booting MiniMyth

Moderator: Pablo

Post Reply
wroopy
Contributor
Posts: 56
Joined: Fri Oct 12, 2007 11:21 pm

Module coretemp is not loaded automatically

Post by wroopy » Sun Jan 11, 2009 1:39 am

Hi!

Since the change to perl-based handling of the kernel module coretemp is not loaded automatically.


The problem is in /etc/rc.d/init.d/conf/MM_HARDWARE.pm. The removal of spaces around comma (,) in the cpu2kernel.map only removes spaces for the first comma not the rest. To fix it I added g as an operator the regexp.

/etc/rc.d/init.d/conf/MM_HARDWARE.pm, line 43

Code: Select all

                        s/ ?, ?/,/g;
Previously:

Code: Select all

                        s/ ?, ?/,/;
/Andreas

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Mon Jan 12, 2009 12:44 am

Thank you for troubleshooting the problem. I have included the fix in the latest test build.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

wroopy
Contributor
Posts: 56
Joined: Fri Oct 12, 2007 11:21 pm

Post by wroopy » Mon Jan 12, 2009 8:57 am

Verified and works fine in 0.21.0-64b2-nvidia.180.22

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Tue Jan 13, 2009 2:31 am

I am glad that it is working.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Post Reply