Video problem running on VirtualBox

Help with booting MiniMyth

Moderator: Pablo

Post Reply
MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Video problem running on VirtualBox

Post by MythLegend » Wed Feb 04, 2009 11:59 am

Hi,
Has anyone managed this ?
I'm using 0.21.0-61, have setup a virtual machine but when booting it says :
"error: no supported video hardward found."
Is there any way to get this working ?
Thanks.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed Feb 04, 2009 4:29 pm

Try 0.21.0-64. There have been VMware related changes since 0.21.0-61 that might help.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Wed Feb 04, 2009 6:00 pm

OK, I tried the latest stable (64) and it now says:
MM_INIT_TYPE=sh is invalid
Kernel Panic,
having removed this (MM_INIT_TYPE=sh) from the end of the file in pxelinux.cfg and now it gets a bit further before saying :
MM_X_DRIVER='' is not valid

I have the output of lspci -mn :
root@virtmyth1:/var/log # lspci -mn
00:00.0 "0600" "8086" "1237" -r02 "" ""
00:01.0 "0601" "8086" "7000" "" ""
00:01.1 "0101" "8086" "7010" -p8a "" ""
00:02.0 "0300" "80ee" "beef" "" ""
00:03.0 "0200" "1022" "2000" -r40 "1022" "2000"
00:04.0 "0880" "80ee" "cafe" "" ""
00:05.0 "0401" "8086" "2415" -r01 "8086" "0000"
00:07.0 "0680" "8086" "7113" -r08 "" ""

When I boot up a virtual knoppix machine, it tells me :
Video is Unknown vendor|unknown device 80ee:beef, using XFree86(vesa) Server

Any idea what I should specify in the MM_X_DRIVER ?

Thanks.
Last edited by MythLegend on Wed Feb 04, 2009 7:34 pm, edited 1 time in total.

frbaresi
Member
Posts: 26
Joined: Fri Jan 16, 2009 6:53 pm

Post by frbaresi » Wed Feb 04, 2009 7:16 pm

I have the same problem with Virtual BOx, but, with VMware I have no problems.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Post by Pablo » Wed Feb 04, 2009 7:46 pm

It appears that VirtualBox requires its own Xorg driver, which is not included in MiniMyth.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

MythLegend
Contributor
Posts: 56
Joined: Thu Jul 12, 2007 7:46 pm

Post by MythLegend » Wed Feb 04, 2009 7:55 pm

Even without the Xorg driver, it was useful today in as the MM_INIT_TYPE=sh error was visible when I tried version 0.21.0-64 on the virtualbox but only about half (the lower half) was visible on the TV with my SP8000E setup, so difficult to make out.

Post Reply