Can't get pxe boot working

Help with booting MiniMyth

Moderator: Pablo

Post Reply
jpifer
New Member
Posts: 2
Joined: Thu Mar 26, 2009 12:57 pm

Can't get pxe boot working

Post by jpifer » Thu Mar 26, 2009 1:17 pm

I'm trying to setup minimyth for the first time. I have a tftpserver already running on my myth backend because I used to use mvpmc. Anyway, I have this on my dhcp server:
host mythfe-fe3 {
hardware ethernet 00:08:02:5D:44:55;
fixed-address 192.168.1.13;
option host-name "mythfe-fe3";
next-server 192.168.1.16;
filename "/minimyth-0.21.0-64-nvidia.180.22/pxelinux.0";
}

From another machine I can tftp and grab pxelinux.0 fine, so tftp is working.

contents of pxelinux.o:
DEFAULT minimyth-nfs

LABEL minimyth-nfs
KERNEL minimyth-0.21.0-64-nvidia.180.22/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=192.168.1.16:/mythtv/minimyth/minimyth-0.21.0-64-nvidia.180.22 MM_MINIMYTH_BOOT_URL="http://192.168.1.16/minimyth/"

I when I try booting the PC it successfully gets the right ip address, but it stops. I ran wireshark on the server running tftp and I see:
192.168.1.13 192.168.1.16 TFTP Read Request, File: /minimyth-0.21.0-64-nvidia.180.22/pxelinux.0\000, Transfer type: octet\000
192.168.1.16 192.168.1.13 TFTP Option Acknowledgement
192.168.1.13 192.168.1.16 TFTP Error Code, Code: Not 192.168.1.13 192.168.1.16 TFTP Read Request, File: /minimyth-0.21.0-64-nvidia.180.22/pxelinux.0\000, Transfer type: octet\000
192.168.1.16 192.168.1.13 TFTP Option Acknowledgement
192.168.1.13 192.168.1.16 TFTP Acknowledgement, Block: 0
192.168.1.16 192.168.1.13 TFTP Data Packet, Block: 1 (last)
192.168.1.13 192.168.1.16 TFTP Acknowledgement, Block: 1

Obviously there's an error code, but the following data block appears to contain the data in pxelinux.0.

I'm stuck at this point. Haven't worked a lot with pxe booting. Any help is appreciated.

Thanks,
James

thekorn
Contributor
Posts: 71
Joined: Wed Dec 31, 2008 8:45 am

Post by thekorn » Sat Apr 04, 2009 1:04 am

Man, this is going back a few months, but pxelinux has some specific requirements for the tftp server. I remember digging pretty far on the syslinux site and finding them. Long story short, there was a patch that was suppossed to make pxelinux work with "any old" tftp server, but in my experience it didn't really work reliably as it introduced a new bug.

What tftp daemon are you running? I had strange pxelinux boot problems on ubuntu until I switched to tftp-hpa. tftp and pxelinux has been running smooth and trouble-free ever since!

(and as a nice side benefit, tftp-hpa is wayyyy faster! :) )

jpifer
New Member
Posts: 2
Joined: Thu Mar 26, 2009 12:57 pm

tftp version

Post by jpifer » Sat Apr 04, 2009 1:55 am

Not exactly sure which it is, but rpm is:
tftp-server-0.48-6.fc9.i386

Thanks for the suggestion. I will look at other tftp servers.

James

tsjoender
Contributor
Posts: 87
Joined: Mon Nov 05, 2007 9:45 am
Location: Friesland, The Netherlands

Post by tsjoender » Sun Apr 05, 2009 9:54 am

What is pxelinux.o is that pxelinux.0 by any chance? That should not be a textfile with the contents you show below. If that is the case then you could try the following:

Move your current pxelinux.0 to /tftpboot/pxelinux.cfg/default (or replace default with the mac address of the client using this notation: 00-11-22-33-44-55). Then take a new copy of the pxelinux.0 file from here: /usr/lib/syslinux/pxelinux.0 and copy that to /tftpboot/pxelinux.0.

Post Reply