Page 1 of 1

Boot stops at "waiting for directory /minimyth to mount

Posted: Thu Apr 30, 2009 2:59 am
by WittFan
Due to a hard drive crash I had to rebuild my mythtv backend from scratch. Before the crash this system had also been a pxelinux server for a diskless minimyth frontend with a RAM root file system.

I've got everything working again except the network boot. I'm using ram-minimyth-0.21.0-66-x86_64. On booting the minimyth frontend finds and loads the kernel and rootfs files. It then goes to the splash screen where it stops when it gets to "waiting for directory /minimyth to mount." Switching to the console just shows "INIT: Entering runlevel: 5." I cannot telnet in to the frontend (connection refused), but I can ping it and get it too gracefully shut down with ctrl+alt+del.

I have no idea how to start debugging this thing. Any suggestions?

FWIW, /var/lib/tftpboot/X86PC/linux/pxelinux.cfg/default reads:

Code: Select all

# DO NOT EDIT auto_generated by
DEFAULT minimyth-ram
DISPLAY messages
F1 help.txt

label local

label minimyth-ram
    KERNEL minimyth-0.21.0-66-x86_64/kernel
    APPEND ro root=/dev/ram0 ramdisk_size=96000 initrd=minimyth-0.21.0-66-x86_64/rootfs
and my file layout is:

Code: Select all

and /var/lib/tftpboot/X86PC/linux/conf/default/minimyth.conf reads:

Code: Select all


Posted: Thu Apr 30, 2009 3:15 am
by Pablo
My best guess is that your DHCP server has changed. MiniMyth requires that the DHCP server provide MiniMyth host with the bootfile path (the 'filename' option when using ISC's DHCP) all the time, not just when the MiniMyth host identifies itself as a PXEClient. Often, PXE boot instructions include configuration that restricts the DHCP server to providing the bootfile path only when the host identifies itself as a PXEClient.

Posted: Thu Apr 30, 2009 3:35 am
by WittFan
My DHCP server hasn't changed but I did have to rebuild /etc/dhcpd.conf from scratch. (Actually I was lazy and let the DHCP and PXE configuration wizards do it.) It is now jammed full of PXE stuff. To be honest, I don't understand most of the stuff in there. :?

Any idea how to find out if there exists a bootfile restriction?

Posted: Thu Apr 30, 2009 4:10 am
by Pablo
If you post the /etc/dhcpd.conf file, then I can take a look at it.

If the 'filename' statement is enclosed in a 'class' statement that limits it to the PXEClient class, then it would be limited. For example:

Code: Select all

class "PXEClient" {
    match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";

    filename  "<filename>";

Code: Select all

if substring(option vendor-class-identifier, 0, 9) = "PXEClient" {
    filename "<filename>";

Posted: Thu Apr 30, 2009 5:25 am
by WittFan
You're brilliant Pablo! That was it. I rebuilt my dhcpd.conf by hand and now it boots just fine.

Thanks a million!

Posted: Mon May 04, 2009 4:38 am
by Pablo
I am glad that you were able to get everything working again.