Page 1 of 1

Failed to mount /minimyth

Posted: Thu Sep 24, 2009 3:49 pm
by Airic37
I've been running a local minimyth install off of a thumb drive for quite a while with great success. Thanks for providing this great distribution.

The thumb drive seems to have gotten rather "flaky" lately and rather than buy another, I decided I'd learn something new and convert the frontend over to netboot. I followed the Network Boot using PXELINUX with a RAM Root File System instructions and had the front end finding and booting pxelinux rather quickly. However, the boot process hangs with Failed to mount /minimyth. I'm sure this is an obvious oversite on my part but I just can't figure out. Any help would be greatly appeciated.

Re: Failed to mount /minimyth

Posted: Thu Sep 24, 2009 5:42 pm
by Pablo
MiniMyth uses a "hack" (actually two "hacks") to decide the location of the boot directory. It needs to know this in order to retrieve configuration files and themes. Basically, the hack is that if the DHCP server provides filename, then MiniMyth assumes that you are network booting. Otherwise, it assumes you are local booting and waits for /minimyth to mount. Therefore, you DHCP server should provide the MiniMyth clients with the BOOTP filename even when the client is not identifying itself as a PXE client. If for some reason you cannot do this, then you can add MM_MINIMYTH_BOOT_URL to your boot line, which will override the logic used by MiniMyth.

Re: Failed to mount /minimyth

Posted: Thu Sep 24, 2009 8:02 pm
by Airic37
Thanks for the quick reply. I had narrowed in on MM_MINIMYTH_BOOT_URL likely being the solution. But, admitting my ignorance of DHCP/TFTP/BOOTP, I'm still not able to put the pieces together. Doesn't a successful boot imply that the BOOTP filename is being passed correctly and that minimyth should then be able to correctly guess that we are netbooting and choose the correct location? If it helps, the relevant part of dhcpd.conf I have:

subnet 192.168.0.0 netmask 255.255.255.0 {
range dynamic-bootp 192.168.0.100 192.168.0.199;
option routers 192.168.0.1;
filename "minimyth/pxelinux.0";
}

Re: Failed to mount /minimyth

Posted: Fri Sep 25, 2009 2:35 pm
by Pablo
Do you have the option 'next-server' configured in your DHCP server? If not, then MiniMyth will not know the address of the TFTP server containing the file minimyth/pxelinux.0. Many PXE clients try other possible IP addresses in the BOOTP message when next-server is not configured, but MiniMyth does not.