Page 1 of 1

Can't mount /minimyth

Posted: Sat Sep 26, 2009 9:57 pm
by nickrout
I am trying to boot locally from a cf card in an ide-cf adaptor and then mount over nfs. The cf card has been freshly partitioned with cfdisk to contain one fat16 partition and that partition has then been treated to mkfs.msdos and syslinux according to the instructions on the web page.

The syslinux.cfg file has been amended to read as per this suggestion:

http://www.minimyth.org/forum/viewtopic.php?f=5&t=2114

The system boots to the point where the nice graphical screen is present, which complains about being unable to mount /minimyth.

/var/log/messages says:
Sep 26 08:32:32 192 syslog.info syslogd started: BusyBox v1.14.2
Sep 26 08:32:43 192 daemon.info init: Entering runlevel: 5
Sep 26 08:32:47 192 local0.info minimyth: starting splash screen
Sep 26 08:32:48 192 local0.info minimyth: configuring shared libraries ...
Sep 26 08:32:49 192 local0.info minimyth: starting loopback network interface ...
Sep 26 08:32:49 192 auth.notice portmap[200]: Only binding to LOOPBACK address!
Sep 26 08:32:49 192 local0.info minimyth: starting DHCP client ...
Sep 26 08:32:49 192 local0.info minimyth: running DHCP client command '/sbin/udhcpc -S -p /var/run/udhcpc.pid -s /etc/udhcpc.script -i eth0 -r 192.168.1.124 -q > /var/log/udhcpc 2>&1'.
Sep 26 08:32:49 192 daemon.info udhcpc[214]: udhcpc (v1.14.2) started
Sep 26 08:32:49 192 daemon.info udhcpc[214]: Sending discover...
Sep 26 08:32:49 192 daemon.info udhcpc[214]: Sending select for 192.168.1.124...
Sep 26 08:32:49 192 daemon.info udhcpc[214]: Lease of 192.168.1.124 obtained, lease time 86400
Sep 26 08:32:50 192 local0.info minimyth: fetching configuration file ...
Sep 26 08:32:51 192 local0.info minimyth: waiting for directory /minimyth to mount (30 second(s) left) ...
Sep 26 08:32:52 192 local0.info minimyth: waiting for directory /minimyth to mount (29 second(s) left) ...
Sep 26 08:32:53 192 local0.info minimyth: waiting for directory /minimyth to mount (28 second(s) left) ...
[snip repeated lines]
Sep 26 08:33:22 192 local0.info minimyth: waiting for directory /minimyth to mount (1 second(s) left) ...
Sep 26 08:33:23 192 local0.err minimyth: directory /minimyth failed to mount.
Sep 26 08:33:24 192 local0.info minimyth: init failed. check '/var/log/messages' for further details.
Sep 26 08:33:24 192 daemon.info init: no more processes left in this runlevel
dmesg shows no sign of any device called sd* or hd* and lsmod makes no mention of ide. I think the ide device is being detected. What next?

Re: Can't mount /minimyth

Posted: Sun Nov 28, 2010 1:47 am
by TomF
Hi nickrout,

did you get anywhere? I seem to have exactly the same problem. everything worked fine with 0.22.0-72.
After copying all the updated files from 0.22.0-74 on the cf card it seems that it isn't detected anymore. My system hangs at the same lines of output as yours.

There isn't even an entry /dev/diskXXX so I can't mount the card.

Does anybody have an idea where to look? Could this be some sort of timing issue?

Tom

Re: Can't mount /minimyth

Posted: Fri Dec 03, 2010 1:16 am
by TomF
I am still trying to get 0.22.0-74 to do a local boot. Out of curiosity I also tried to boot the latest version 0.24.0-75b6. And that worked. So I checked the changelog to see what might have caused / repaired the problem.

It says:

Code: Select all

Fixed bugs
    - Fixed a bug in unionfs that caused it to oops when using the Nvidia
      260.19.12 driver.
    **********- Re-enabled ATA/PATA/SATA support in the kernel, which had become
      disabled at some point.**********
    - Updated eventlircd to fix broken key mappings.
    - Fixed duplicate text in the frontend's tools menu.
    - Fixed bug that caused init to fail for MythTV 0.24 and newer when 
      MM_MEDIA_DVD_RIP_URL is set due to mtd not being present.
So I guess there is just no ATA support in version 74. Perhaps my next step will be to try to boot from an USB stick.

Re: Can't mount /minimyth

Posted: Sat Dec 11, 2010 1:50 am
by Pablo
This should be fixed in 75.