Page 1 of 1

nic support issue ?

Posted: Wed Oct 28, 2009 12:27 pm
by fadetoblack
hi all,

can anyone provide me with a list of nic's supported in minimyth 0.19-22b8 ? i believe that the embedded nic i'm using ( broadcom netxtreme bc5751 ) may not supported. if this is true, then i'd like a list of what is supported. if it is supported, then i know i need to keep working on my current problem.

background :

i have been running minimyth on an asus am2pv-vm which i believe has now died. when i try to power up the power supply and cpu fans spin for about five seconds and then it all shuts down again, no beeps, nothing. i swapped the power supply and ram and still have the same symptoms.

so i tried to boot up minimyth on my test box ( dell sc430 ). i just changed the mac address in my dhcp config to match the new box, so i am relatively certain that my dhcp and tftp setup is correct. what happens when i boot is it hangs with "error: minimyth configuration file not found". after a lot of looking around the web, it seems that this is usually a problem with dhcp, but as i said i don't believe that this is my problem. following one tip, i turned on tracing for my tftp server and get this:

Oct 28 18:52:42 mythtv dhcpd: DHCPDISCOVER from 00:13:72:1c:3d:33 via eth0
Oct 28 18:52:42 mythtv dhcpd: DHCPOFFER on to 00:13:72:1c:3d:33 via eth0
Oct 28 18:52:46 mythtv dhcpd: DHCPREQUEST for ( from 00:13:72:1c:3d:33 via eth0
Oct 28 18:52:46 mythtv dhcpd: DHCPACK on to 00:13:72:1c:3d:33 via eth0
Oct 28 18:52:46 mythtv in.tftpd[29608]: RRQ from filename pxelinux.0
Oct 28 18:52:46 mythtv in.tftpd[29608]: tftp: client does not accept options
Oct 28 18:52:46 mythtv in.tftpd[29609]: RRQ from filename pxelinux.0
Oct 28 18:52:46 mythtv in.tftpd[29610]: RRQ from filename pxelinux.cfg/0A00000A
Oct 28 18:52:46 mythtv in.tftpd[29611]: RRQ from filename minimyth-0.19-22b8/kernel
Oct 28 18:52:46 mythtv in.tftpd[29613]: RRQ from filename minimyth-0.19-22b8/rootfs

as there's no request for the minimyth config file i suspect that the issue is with the minimyth client, not the dhcp / tftp server. fwiw, i also cannot ping or telnet the minimyth client box.

so i have two questions :


am i right in thinking that this means that the minimyth build i am using does not have the ethernet driver i need ?


where can i find a list of ethernet drivers included in minimyth-0.19-22b8 ? i've browsed the changelogs for minimyth but couldn't find anything helpful.

yes, i know, this is yet another reason i should upgrade. i just wanted an interim solution while i decide how i'm going to fix / replace my current minimyth host - asus m2npv-vm boards ( which have onboard component tv output ) are no longer available.


Re: nic support issue ?

Posted: Sat Oct 31, 2009 4:01 pm
by Pablo
As far as I know this Ethernet adapter requires either the tg3 or bnx2 driver. However, to know for sure, I would need the output of

Code: Select all

lspci -mn
If it requires either of these drivers, then it is not supported in version 22b8 of MiniMyth.

By the way you should be able to retrieve the kernel configuration from /proc/config.gz.

Re: nic support issue ?

Posted: Mon Nov 02, 2009 2:52 am
by fadetoblack
to run 'lspci -nm' should i just hit <ctl-alt-f1> to get to a prompt ? when i do this, i get two lines that say :

INIT: version 2.86 booting
INIT: Entering runlevel: 5

but when i press <enter> the cursor moves down one line but i get no other response. <ctl-8> returns me to the mythtv screen, and <ctl-alt-del> will start off a normal shutdown process, so i know it's not just totally hung. any further tips on what i can do ?

i've tried using MM_DEBUG="yes" to see if anything useful showed up. it does produce lots of output but since i can't scroll up the screen it hasn't really helped.

i also tried MM_X_ENABLED="no", but it looks like my version of minimyth doesn't support this variable.

i put in an old intel ethernet card ( and tracked down fixes for the landesk/tftp issues ) but i still have exactly the same problem. is it likely that this old version of minimyth only included a very limited range of ethernet drivers ? or do you think that perhaps there is some other issue with my hardware that makes it incompatible with minimyth ( i.e should i give up now ) ?

thanx for the pointer to /proc/config.gz - if i get to a prompt i'll know where to look.

Re: nic support issue ?

Posted: Tue Nov 03, 2009 4:08 pm
by Pablo
I do not recall whether or not that version of MiniMyth starts a console. If it does not, then you are out of luck.

Re: nic support issue ?

Posted: Thu Nov 05, 2009 1:47 am
by fadetoblack
no worries - i'll start from scratch and look up what hardware and mythtv version is supported by minimyth and get to work on upgrading.

thanx again.