Page 1 of 1

Booting - Not enough memory to load specified image

Posted: Tue Nov 10, 2009 10:15 am
by eddief
Hi, I"ve been plodding along, trying to get minimyth to boot, meanwhile learning about PXE, but I can't get past booting.

I've mostly been wrestling with ram-minimyth-0.21.0-71, and tried 0.22.0 - both have the same problem

Loading minimyth-0.21.0-71/kernel..........
Loading minimyth-0.21.0-71/rootfs............
Not enough memory to load specified image.

The client machine, the machine to actually run minimyth, has 448MB of RAM. It runs MythTV too.

On the server side I've tried to mount rootfs to look inside. It runs Slackware 12.2. I installed kernel and enabled squashfs 4.0, modprobed it, but rootfs refuses to mount. I've also tried to mount *.sfs files. No good either.

# file kernel
kernel: Linux kernel x86 boot executable RO-rootFS, root_dev 0x901, swap_dev 0x1, Video mode 786

# file rootfs
rootfs: Squashfs filesystem, little endian, version 4.0, 18562238207 bytes, 7735 inodes, blocksize: 4 bytes, created: Fri Dec 5 18:25:52 2014

18562238207 bytes????!!!!! Is rootfs or "file" screwed up?

When I try to mount rootfs,
mount -t squashfs -o loop rootfs /mnt/iso

mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

No errors in syslog or messages or debug.

WHAT am I missing???

Thanks, Eddie

Re: Booting - Not enough memory to load specified image

Posted: Wed Nov 11, 2009 11:39 pm
by Pablo
The fact that file reports a completely wrong file size should not be a problem as it does the same thing on my system.

It is likely that you cannot mount it because MiniMyth uses squashfs 4.0 patched with LZMA support, which I doubt has made it into any distribution.

Could you post the contents of your pxelinux.cfg file?

Re: Booting - Not enough memory to load specified image

Posted: Sun Nov 15, 2009 7:51 am
by eddief
Pablo, Thanks for your reply. Sorry I didn't respond sooner - I took a few days off with other stuff.

I found out about the need for lzma from I believe lzma is now available in 2.6.30.

I'm using pxeconfig.cfg/default, unmodified from pxe-minimyth-0.21.0-71.tar.bz2

DEFAULT minimyth-ram

LABEL minimyth-ram
KERNEL minimyth-0.22.0-71/kernel
APPEND ro root=/dev/ram0 ramdisk_size=96000 initrd=minimyth-0.22.0-71/rootfs

LABEL minimyth-nfs
KERNEL minimyth-0.22.0-71/kernel
APPEND ro root=/dev/nfs ip=dhcp nfsroot=


I'm using PXE - not NFS.