Can't boot NFS root file system

Help with booting MiniMyth

Moderator: Pablo

Post Reply
yalu
New Member
Posts: 4
Joined: Mon Dec 21, 2009 8:50 pm

Can't boot NFS root file system

Post by yalu » Mon Dec 21, 2009 8:57 pm

That results in a kernel panic, off course. Tried adding "debug" to the kernel command line but that didn't give me more output. What I know is that the mount request never reaches the NFS server. I use it daily for my PC's so no problem there, I definitely know how remote booting works and the configuration seems OK.

So:
- how can I get more debugging info from the kernel? Is it compiled without the messages on?
- maybe the network card simply isn't compiled in. I need the tulip driver. Where can I find the kernel config?

I use version 0.21.0-72. 0.21 is because my back-end is still 0.21.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: Can't boot NFS root file system

Post by Pablo » Mon Dec 21, 2009 9:27 pm

The tulip driver is included. You can find the kernel config in the gar build system tarball at gar-minimyth-<minimty_version>/script/kernel-<kernel_version>/linux/files/linux-<kernel_version>-i386-pentium-mmx.conf or in svn at http://code.google.com/p/minimyth/sourc ... mmx.config.

What does your pxeconfig file contain?
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

yalu
New Member
Posts: 4
Joined: Mon Dec 21, 2009 8:50 pm

Re: Can't boot NFS root file system

Post by yalu » Tue Dec 22, 2009 11:04 am

Pablo wrote:The tulip driver is included. You can find the kernel config in the gar build system tarball at gar-minimyth-<minimty_version>/script/kernel-<kernel_version>/linux/files/linux-<kernel_version>-i386-pentium-mmx.conf or in svn at http://code.google.com/p/minimyth/sourc ... mmx.config.

What does your pxeconfig file contain?
OK, good. I worked out the error, the pxelinux config file was actually never read. So fixed my configuration.

By the way, in the kernel configuration it says:

# CONFIG_X86_VERBOSE_BOOTUP is not set

You may just as well enable this, the errors can always be suppressed by adding "quiet" to the kernel command line.

Post Reply