Page 1 of 1

VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Thu Jul 22, 2010 7:54 pm
by GloomyTrousers
Hi,

I've just upgraded my MM box (ram-minimyth) from 0.22.0-73b2-x86_64 to 0.23.0-73b11-x86_64 and cannot get it to boot. The error is "Kernel panic - not syncing: VFS: unable to mount rootfs on unknown-block(1,0)" (immediately after loading the initrd).

I found one old thread but I'm guessing it's outdated; I can't see how to change the kernel parameters when doing an automated install. Can anyone shed any light on where I should be looking?

Thanks,

Russ

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Sat Jul 24, 2010 9:17 am
by pleeke
just a thought, but when you extracted the root filesystem are you sure you did it as root user? Think it needs to be done as root to create some of the dev nodes (or something) correctly

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Sat Jul 24, 2010 9:47 am
by GloomyTrousers
Yeah, I ran "sudo ./mm_local_install ..." and there were no errors reported. IIRC if you run the install script as a normal user it throws various errors.

Thanks,

Russ

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Tue Jul 27, 2010 7:41 pm
by kdewaal
Your problem could be caused by the size of your root file system.
I have increased the size of the root file system from 96k to 128k when upgrading from 0.22 to 0.23 (option ramdisk_size=128000).

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Sun Aug 01, 2010 8:47 am
by GloomyTrousers
Thanks! I see it's in the FAQ, but with a slightly different error message which is probably why I didn't find it.That got me up and running, at least as far as the next error ("MythContext: Connecting to backend server: 127.0.0.1:6543" new topic on the way if I can't resolve it)...

Russ

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Tue Aug 03, 2010 3:25 pm
by Pablo
GloomyTrousers wrote:Thanks! I see it's in the FAQ, but with a slightly different error message which is probably why I didn't find it.
It appears that the error message from the kernel was changed slightly. I have updated the FAQ.

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Sat Aug 14, 2010 9:03 am
by GloomyTrousers
Just a thought: would it make sense to have "ramdisk_size=128000" the default, at least for those versions which require it (guessing x86_64)?

Russ

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Wed Sep 22, 2010 4:15 pm
by Pablo
I have increased the ramdisk size to 128000 in the documentation and committed the change to SVN.

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Sat Sep 17, 2011 5:02 pm
by GloomyTrousers
FYI, with version 0.24.1-77-x86_64, ramdisk_size=128000 is not quite large enough to fit the "rootfs" file, which is now 129.5MB. I've increased it to 160000 which should be plenty and it now works.

Re: VFS: unable to mount rootfs on unknown-block(1,0)

Posted: Mon Nov 21, 2011 7:07 pm
by Pablo
Thank you. I have updated the documentation to reflect the larger image size. I changed it from 128000 to 192000.