Page 1 of 1

CF-IDE force PIO mode

Posted: Sun Feb 13, 2011 2:21 pm
by martingu
Hi!

I've been using minimyth for a very long time now, I think my first MythTV version was 0.15 (just the time when DVB was introduced to the code) and it was not long from then that I started using minimyth for my frontends...

In all those years it hasn't been until now that I needed to post a question myself on the forum:

For one reason or another I want to boot from a CF media using a CF-IDE adapter on my Epia MII-6000. As you are aware, most CF-IDE adapters don't support DMA, so it's bound to PIO mode.

Unfortunately, minimyth tries to initialize it with MWDMA2 first, prolonging the boot-process for about 30 seconds. Then it continues to try MWDMA1, taking another 30 seconds.

After that PIO 4 is chosen and the boot process continues as expected.

I have already tried adding the ide=nodma option to the syslinux.cfg but with no success. Also, setting PIO 4 in the BIOS doesn't help (Linux doesn't give a d**n about the BIOS, I know).


Browsing the syslinux Wiki did not bring up a solution either.... So my question is: How can I force minimyth into PIO mode 4?

Thanks in advance for your help!

Best wishes,
Martin

Re: CF-IDE force PIO mode

Posted: Mon Feb 14, 2011 12:54 am
by Pablo
Odd. I have no idea why it is doing this.

First, ide=nodma should disable DMA. Second, a patch applied to the MiniMyth kernel should cause it to disable DMA for each ATA interface that is recognized as Compact Flash Adapter (CFA). I added the patch some years ago so that MiniMyth could boot from CF without requiring disabling DMA on all drives, as disabling DMA on all drives caused problems with DVD playback.

However, as I no longer have a VIA EPIA M motherboard and I no longer boot using a CF-IDE adapter, it has been some time since I tested whether or not this pack works. I will search for my CF-IDE adapter (we moved a year ago after living in the same house for 17 years and I have yet to sort through all the boxes) so that I can use it to troubleshoot the problem.

Re: CF-IDE force PIO mode

Posted: Mon Feb 14, 2011 8:39 pm
by martingu
I have tried this with two completely different adapters so there might really be something wrong.

I will check my config again or maybe try to find an alternative to cf-ide boot.

Re: CF-IDE force PIO mode

Posted: Wed Feb 16, 2011 11:38 am
by lofty69
I've been booting my Via MII10000 off a CF card (using an IDE/CF adapter) for years without any issue. I've recently upgraded to an ION based board only so I can watch HD.

Re: CF-IDE force PIO mode

Posted: Fri Feb 18, 2011 5:02 am
by Pablo
So far, I have not been able to find my CF-IDE adapter. I will continue to look this weekend.

Re: CF-IDE force PIO mode

Posted: Mon Mar 14, 2011 7:38 pm
by martingu
I have decided to boot via iPXE. Works for me so no need for cf-ide booting on my side