Neoware CA5 X start problems

Help with booting MiniMyth

Moderator: Pablo

Post Reply
sonichouse
New Member
Posts: 4
Joined: Thu May 26, 2011 11:30 am

Neoware CA5 X start problems

Post by sonichouse » Thu May 26, 2011 3:57 pm

Hi I have tried to solve this, but I am stumped.

I have a Neoware CA5 booting and fetching kernel/rootfs using PXE.

The error states that the audio device cannot be found.

I have had to force the MM_X_DRIVER='sis' for it to get past the unknown driver issue, I know the documentation say I do not need to do this, but I cannot find a valid list of values. Modprobe shows sis_agp is loaded.

lspci gives

Code: Select all

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 550 Host (rev 01)
00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:01.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
00:01.4 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7019 Audio Accelerator
00:02.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 550 PCI/AGP VGA Display Adapter
lspci -nm gives

Code: Select all

00:00.0 "0600" "1039" "0550" -r01 "" ""
00:00.1 "0101" "1039" "5513" -rd0 -p80 "1039" "5513"
00:01.0 "0601" "1039" "0018" "" ""
00:01.2 "0c03" "1039" "7001" -r07 -p10 "" ""
00:01.4 "0401" "1039" "7019" "" ""
00:02.0 "0604" "1039" "0001" "" ""
00:0a.0 "0200" "10ec" "8139" -r10 "10ec" "8139"
01:00.0 "0300" "1039" "5315" "1039" "5300"
My minimyth.cfg is

Code: Select all

MM_X_OUTPUT_HDMI='none'
MM_X_OUTPUT_DVI='none'
MM_X_OUTPUT_TV='none'
MM_X_OUTPUT_VGA='auto'
MM_X_MODE='800x600'
MM_X_DRIVER='sis'

MM_AUDIO_TYPE='analog'
MM_AUDIO_CARD_NUMBER='1'
MM_AUDIO_DEVICE_NUMBER='4'
The minimyth.log gives

Code: Select all

minimyth: configuring audio ...
minimyth: the audio driver does not appear to be loaded.
Exiting eval via last at /etc/rc.d/rc.pl line 80.
minimyth: init failed. check '/var/log/messages' for further details.
The Xorg.log gives

Code: Select all

[751564.952] (==) Log file: "/var/log/Xorg.0.0.log", Time: Thu May 26 15:53:42 2011
[751565.005] (==) Using config file: "/etc/X11/xorg.conf"
[751565.006] (==) Using config directory: "/etc/X11/xorg.conf.d"
[751565.016] Parse error on line 2 of section Files in file /etc/X11/xorg.conf
        "@NVIDIA_TRUE@" is not a valid keyword in this section.
[751565.018] (EE) Problem parsing the config file
[751565.018] (EE) Error parsing the config file
Any ideas ?

Is there any other information required to diagnose this issue ?

sonichouse
New Member
Posts: 4
Joined: Thu May 26, 2011 11:30 am

Re: Neoware CA5 X start problems

Post by sonichouse » Wed Jun 22, 2011 7:18 pm

Is it time to find another use for this machine ?

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: Neoware CA5 X start problems

Post by Pablo » Thu Jun 23, 2011 1:16 am

The problem is that (1) MiniMyth does not have the sound driver for the sound hardware in that system, and (2) MiniMyth does not know about the PCI product ID for the video hardware in that system. I can fix both of these problems easily. However, whether or not this system can be used as a MythTV frontend depends on at least two things: (1) does it have a powerful enough CPU to decode the audio and video streams and (2) does it have enough memory to run MiniMyth? From what I have found on the Neoware CA5, it has a processor speed of 200MHz and a maximum memory of 256MB. If this is the case, then I believe the CPU is too underpowered and the maximum memory is too little.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

sonichouse
New Member
Posts: 4
Joined: Thu May 26, 2011 11:30 am

Re: Neoware CA5 X start problems

Post by sonichouse » Thu Jun 23, 2011 5:12 pm

Thanks for the followup.
Pablo wrote:The problem is that (1) MiniMyth does not have the sound driver for the sound hardware in that system, and (2) MiniMyth does not know about the PCI product ID for the video hardware in that system. I can fix both of these problems easily.
If you want to add them in to the next build I will gladly try it.
Pablo wrote:However, whether or not this system can be used as a MythTV frontend depends on at least two things: (1) does it have a powerful enough CPU to decode the audio and video streams and (2) does it have enough memory to run MiniMyth?
The info I found is http://www.parkytowers.me.uk/thin/NeoCA5/index.shtml
Pablo wrote:From what I have found on the Neoware CA5, it has a processor speed of 200MHz and a maximum memory of 256MB. If this is the case, then I believe the CPU is too underpowered and the maximum memory is too little.
It can run DSL linux, but as you say, it may be a stretch to run mythfrontend on it.

Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

Re: Neoware CA5 X start problems

Post by Pablo » Sun Jun 26, 2011 4:46 pm

sonichouse wrote:Thanks for the followup.
Pablo wrote:The problem is that (1) MiniMyth does not have the sound driver for the sound hardware in that system, and (2) MiniMyth does not know about the PCI product ID for the video hardware in that system. I can fix both of these problems easily.
If you want to add them in to the next build I will gladly try it.
I have committed the changes to SVN, so they will be in the 78b2 test build.
Pablo wrote:However, whether or not this system can be used as a MythTV frontend depends on at least two things: (1) does it have a powerful enough CPU to decode the audio and video streams and (2) does it have enough memory to run MiniMyth?
The info I found is http://www.parkytowers.me.uk/thin/NeoCA5/index.shtml
Pablo wrote:From what I have found on the Neoware CA5, it has a processor speed of 200MHz and a maximum memory of 256MB. If this is the case, then I believe the CPU is too underpowered and the maximum memory is too little.
It can run DSL linux, but as you say, it may be a stretch to run mythfrontend on it.
I suspect that this CPU will not be powerful enough to decode MPEG2 SDTV resolution video and this memory will not be large enough to run mythfrontend. Of course, the only way to know for sure it to try it.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

sonichouse
New Member
Posts: 4
Joined: Thu May 26, 2011 11:30 am

Re: Neoware CA5 X start problems

Post by sonichouse » Mon Dec 12, 2011 6:31 pm

Sorry, been a while since I had time to sit down and test this.

Using 0.24-1-78 I get

Code: Select all

Dec 12 17:27:31 (none) local0.info minimyth: processing configuration file ...
Dec 12 17:28:07 (none) local0.warn minimyth: 'unknown audio device. assuming audio gain is '90'.
my minimyth.conf file has

Code: Select all

MM_X_OUTPUT_HDMI='none'
MM_X_OUTPUT_DVI='none'
MM_X_OUTPUT_TV='none'
MM_X_OUTPUT_VGA='auto'
MM_X_MODE='800x600'
MM_X_DRIVER='sis'

MM_AUDIO_TYPE='analog'
MM_AUDIO_CARD_NUMBER='1'
MM_AUDIO_DEVICE_NUMBER='4'
How do I need to specify the new driver ?

Post Reply