Blue Screen when booting Asus AT5IONT-I

Help with booting MiniMyth

Moderator: Pablo

Post Reply
New Member
Posts: 8
Joined: Sun Jan 22, 2012 9:25 pm

Blue Screen when booting Asus AT5IONT-I

Post by mikep »

I've upgraded my VIA minimyth frontend by replacing the motherboard, ready for HD (UK-Freeview).

Minimyth 0.24.1-77

I have given the host with this board a new name, IP address and a copy of minimyth.conf so that I can get it running alongside the old box until I fix the inevitable config issues. The new minimyth.conf has been updated to reference VDPAU where appropriate.

It boots as far as starting X and then I get a plain blue screen. Nothing much else happens. Looking in the logs I see that minimyth seems to be trying to find a 'mainmenu.xml' without success. I have been using the 'mythcenter-wide' theme. This same software configuration boots my VIA LN8000 board without any problems.

Since 'mythcenter-wide' works when used with the VIA board, why does it seem to fail when used with the Asus board? This must be something to do with the fact that it's nVidia rather than VIA. Perhaps the cache contents aren't compatible? The new system hasn't yet got as far as creating a theme cache under the new hostname, though.

Is there some other kind of special care I should use when setting up a minimyth.conf for use with VDPAU? Or perhaps there is some other problem here, related to the new hardware, perhaps? Do I gain anything by upgrading to 0.24.1-78?
New Member
Posts: 8
Joined: Sun Jan 22, 2012 9:25 pm

Re: Blue Screen when booting Asus AT5IONT-I

Post by mikep »

Further Information

The TV is a 32" Hitachi LCD Model L32HP04U A
- This works perfectly well with my existing VIA board, which feeds via the VGA input. Obviously, I'm trying to get the new board to work via one of the two HDMI inputs.

Motherboard is an Asus AT5IONT-I
- Dual-core D525 Atom processor. I can't find *anywhere* that actually specifies a clock rate...
- Intel NM10 chipset.
- nVidia GT2010 graphics processor
- 4GB installed memory, although 2 would probably have been enough

I have built a complete duplicate host so that I can debug without affecting WAF. There is no hard drive on this host. Currently testing with a wireless keyboard.

I have upgraded the software to 0.24.1-78. This resides in a completely separate tree (and NFS share) on the server, to ensure there is no possible interaction with the existing host and setup.

The 'Blue Screen' referred to in my original post is a single hue. It appears to be the same hue the TV shows when there is no signal, but in that case there is a 'No Signal' message in the middle of the screen. When I boot the host, once the startup is complete and X is started the screen is entirely blank.

However, it has not hung at that point. I can see traffic on the temporary hub I have installed for perhaps a minute or two after the blue screen is displayed. If I go to my desktop - at the other end of the house and up a flight of stairs, typical - I can log onto the http server on the host and read the log and configuration files. Everything *seems* to be working, except nothing on the display...

A fragment of the log which may indicate a problem, although I don't know sufficient to offer an opinion:

Code: Select all

2012-01-30T11:38:41+00:00 garnet mythfrontend: #011#011#011Name: 'basemediumred'#011Type: 'fontdef'
2012-01-30T11:38:41+00:00 garnet mythfrontend: 2012-01-30 11:38:41.265 MythFontProperties, Error: Failed to load 'DejaVu Sans', got 'Liberation Sans' instead
2012-01-30T11:38:41+00:00 garnet mythfrontend: #011#011#011Location: /usr/share/mythtv/themes/default/base.xml @ 80
2012-01-30T11:38:41+00:00 garnet mythfrontend: #011#011#011Name: 'basemediumyellow'#011Type: 'fontdef'
2012-01-30T11:38:46+00:00 garnet mythfrontend: 2012-01-30 11:38:46.863 XMLParseBase, Error: Unable to load window 'backgroundwindow' from base
2012-01-30T11:38:46+00:00 garnet mythfrontend: 2012-01-30 11:38:46.966 Current MythTV Schema Version (DBSchemaVer): 1264
2012-01-30T11:38:47+00:00 garnet mythfrontend: 2012-01-30 11:38:47.001 New DB connection, total: 2
2012-01-30T11:38:47+00:00 garnet mythfrontend: 2012-01-30 11:38:47.004 Connected to database 'mythconverg' at host:
2012-01-30T11:38:47+00:00 garnet mythfrontend: 2012-01-30 11:38:47.127 MythUIHelper, Error: LoadScaleImage(/usr/share/mythtv/themes/defaultmenu/) failed to load image
2012-01-30T11:39:04+00:00 garnet mythfrontend: 2012-01-30 11:39:04.270 Registering Internal as a media playback plugin.
2012-01-30T11:39:04+00:00 garnet mythfrontend: 2012-01-30 11:39:04.900 Current MythMusic Schema Version (MusicDBSchemaVer): 1017
2012-01-30T11:39:07+00:00 garnet mythfrontend: 2012-01-30 11:39:07.355 MonitorRegisterExtensions(0x40, mp3,mp2,ogg,oga,flac,wma,wav,ac3,oma,omg,atp,ra,dts,aac,m4a,aa3,tta,mka,aiff,swa,wv)
2012-01-30T11:39:07+00:00 garnet mythfrontend: 2012-01-30 11:39:07.641 Loading en_us translation for module mythmusic
2012-01-30T11:39:07+00:00 garnet mythfrontend: 2012-01-30 11:39:07.893 Current MythVideo Schema Version (mythvideo.DBSchemaVer): 1038
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.093 Loading en_us translation for module mythvideo
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.129 NetworkControl: Listening for remote connections on port 6546
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.169 XMLParseBase, Error: Unable to load window 'mainmenu' from 'menu-ui.xml'
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.172 Couldn't find mainmenu.xml for theme 'defaultmenu'
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.174 Overriding broken theme 'defaultmenu' with 'Terra'
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.614 Using Frameless Window
2012-01-30T11:39:09+00:00 garnet mythfrontend: 2012-01-30 11:39:09.616 Using Full Screen Window
2012-01-30T11:39:10+00:00 garnet mythfrontend: 2012-01-30 11:39:10.074 Using the Qt painter
2012-01-30T11:39:21+00:00 garnet mythfrontend: 2012-01-30 11:39:21.874 Found mainmenu.xml for theme 'Terra'
2012-01-30T11:39:38+00:00 garnet mythfrontend: 2012-01-30 11:39:38.237 MythCoreContext: Connecting to backend server: (try 1 of 1)
2012-01-30T11:39:38+00:00 garnet mythfrontend: 2012-01-30 11:39:38.265 Using protocol version 63
2012-01-30T11:47:28+00:00 garnet shutdown[2033]: shutting down for system halt
2012-01-30T11:47:28+00:00 garnet init: Switching to runlevel: 0
2012-01-30T11:47:30+00:00 garnet minimyth: starting splash screen
2012-01-30T11:47:31+00:00 garnet minimyth: stopping X ...
2012-01-30T11:47:31+00:00 garnet minimyth: stopping X
Note at timestamp 2012-01-30 11:38:46.863 there is an XMLParseBase error. Shutdown happens when I push the power button on the unit.

Does this help to pinpoint my problem? This same code works fine when I boot up my VIA host with it. I have full logs if they are required.
Posts: 87
Joined: Mon Nov 05, 2007 9:45 am
Location: Friesland, The Netherlands

Re: Blue Screen when booting Asus AT5IONT-I

Post by tsjoender »

Does the system have multiple display connections (VGA. DVI, HDMI etc)? In that case Minimyth may have picked what it assumes to be display 0 while the TV may be at display 1 or 2. Playing with the MM_X_OUTPUT_HDMI setting may allow you to control this: ... UTPUT_HDMI
New Member
Posts: 8
Joined: Sun Jan 22, 2012 9:25 pm

Re: Blue Screen when booting Asus AT5IONT-I

Post by mikep »

Darn and blast and similar things... I intended to include this information above. The motherboard has an HDMI outpit and a DVI-D output. No VGA, which means I can only test it while it's connected to the TV... major pain.

On startup Xorg.0.0.log reports:

[778572.064] (--) NVIDIA(0): Found 2 heads on board
[778572.064] (II) NVIDIA(0): Supported display device(s): DFP-0, DFP-1

...but previously, the generated Xorg.conf has:

[778570.027] (**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0"

and subsequently:

[778572.065] (II) NVIDIA(0):
[778572.065] (--) NVIDIA(0): Connected display device(s) on ION at PCI:3:0:0
[778572.065] (--) NVIDIA(0): DFP-0
[778572.065] (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[778572.065] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
[778572.065] (--) NVIDIA(0): DFP-0: Native FlatPanel Scaling is not supported
[778572.065] (--) NVIDIA(0): DFP-0: DFP modes are not limited to 60 Hz refresh rate
[778572.065] (--) NVIDIA(0): DFP-0: DFP is not internal to notebook
[778572.065] (--) NVIDIA(0):
[778572.065] (--) NVIDIA(0): --- EDID for DFP-0 ---
[778572.066] (--) NVIDIA(0):
[778572.066] (--) NVIDIA(0): No EDID Available.
[778572.066] (--) NVIDIA(0):
[778572.066] (--) NVIDIA(0): --- End of EDID for DFP-0 ---
[778572.066] (--) NVIDIA(0):

...which I assumed, naturally, was HDMI index 0, so that is what I set for MM_X_OUTPUT_HDMI.
I have also tried the values 'auto' and '1' with exactly the same response.

I'll try these options again, under more controlled conditions, but that won't be until tomorrow now. Thanks for your suggestion.
New Member
Posts: 8
Joined: Sun Jan 22, 2012 9:25 pm

Re: Blue Screen when booting Asus AT5IONT-I

Post by mikep »

Okay, I thought I'd tidy this one up now I have time...

The problem turned out to be a dodgy PSU, which was, amongst other things, putting random settings in the BIOS RAM. I managed to find another PSU for testing purposes and reset the BIOS with the pin header, and everything suddenly burst into life. I discovered that the DVI is output 0 and the HDMI is output 1. Editing the conf file fixed that problem and the system more or less works now.
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla

Re: Blue Screen when booting Asus AT5IONT-I

Post by Pablo »

I am glad you were able to solve the problems. I have been bitten more than once by an insufficient/bad power supply.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.
Post Reply