Page 1 of 1

X broken on A8N-VM CSM with 25.3-82

Posted: Thu Nov 29, 2012 2:16 am
by notfred
The Asus A8N-VM CSM has an NVIDIA GeForce 6150 GPU which lspci reports as 10de:0240. Minimyth 25.2-81 autodetected the nvidia driver for this. There was no specific device entry in /usr/lib/udev/rules.d/05-minimyth-detect-video.rules for this so it triggered off the generic vendor one and it worked well.

I just upgraded to 25.3-82 and this gains an entry for this device id so it gets the nouveau driver. As soon as the driver module loads in to the kernel (progress bar is maybe 1/3 of the way) the video gets corrupted and it also fails to start X. I tried forcing it to the nvidia driver with MM_X_DRIVER='nvidia' but the legacy nvidia driver has been removed so the kernel module fails to load reporting:
NVRM: The NVIDIA GeForce 6150 GPU installed in this system is
NVRM: supported through the NVIDIA 304.xx Legacy drivers. Please
NVRM: visit http://www.nvidia.com/object/unix.html for more
NVRM: information. The 310.19 NVIDIA driver will ignore
NVRM: this GPU. Continuing probe...
NVRM: No NVIDIA graphics adapter found!

Is it possible to add the 304.xx Legacy driver back in to the build and maybe remove this one from the nouveau detection list?

Re: X broken on A8N-VM CSM with 25.3-82

Posted: Thu Nov 29, 2012 2:28 am
by Pablo
Yes. I will add back 304.64, make it the default and update the driver autodetect.

Re: X broken on A8N-VM CSM with 25.3-82

Posted: Sun Dec 02, 2012 5:30 am
by brown_m_k
Pablo wrote:Yes. I will add back 304.64, make it the default and update the driver autodetect.
Thank you Paul!

This also affects the 6150 analog HD outputs on my M2NPV-VM. I reverted back to -81 to work around it for now.

Welcome back! We missed you!

/Mike

Re: X broken on A8N-VM CSM with 25.3-82

Posted: Mon Dec 10, 2012 2:29 am
by jeffborg
Thanks too,

This would also fix my problem (see post in General Help)