Page 1 of 1

tftp problems and solution

Posted: Sat Oct 04, 2003 9:19 pm
by oeris
Hi everyone,

Just wanted to share my success story with tftp booting

After following all directions on this site to setup dhcpd and tftp. My machine would always get stuck on the boot process at the TFTP.. prompt and that would go on pretty much forever. The machine would be getting its dhcp configuration correctly from my server but it seemed that pxelinux.0 would never get transferred.

Trying to troubleshoot, I renamed the pxelinux.0 file and then I would get error messages during boot on both server and client on the fact that the file was not found. So I knew something was working right at least.

Reading up man pages for tftp I saw that you can provide some options that would restrict the use of certain tftp options via the -r command

After a few tries, I've now got everything booting correctly and tftp doing exactly what its supposed to be doing with this server option

server_args = -s /var/lib/tftpboot -r blksize -r blksize2 -r timeout -r utimeout

in the /etc/xinetd.d/tftp file Hopefully this can be of help to someone.

I haven't tried all combinations of the -r option so the 4 I set above might be overkill but they do work for me.

Good luck.

Posted: Mon Oct 06, 2003 6:59 pm
by lmatter
Thanks Oeris, this is good info. Can you tell us what distribution you are running tftp on and which tftp it is?

I'm running Mandrake 9.1, and using the version of tftp they include.

Thanks,
Larry

Posted: Tue Oct 07, 2003 3:34 am
by oeris
tftp-server-0.32-1mdk (mandrake 9.1)
kernel 2.4.21-0.18mdk (pretty standard 9.1 box really)
pxelinux.0 from the latest PXELinux 2.06

My epia board shows Intel UMDI, PXE-2.0 (build 082)
VIA VT6102 Rhine II Fast Ethernet Adapter v2.13 (2002/08/09)

it's an epia m9000 ezra with bios 1.0f

As a side note, I've yet to get the machine to successfully start X. but I'll post questions/results on that on another forum group.

Posted: Tue Oct 07, 2003 8:27 am
by lmatter
Hmmm. Strange that you needed to do that (I didn't) but good to know.

BTW, check the video memory size in the bios. Someone mentioned to me that they had problems with X unless they set it to 32M.

Larry

Posted: Mon Dec 15, 2003 5:38 am
by dhartman
I've read over the comments in this thread and the nice article that Larry wrote for VIA.

I have my dhcp server working. It hands off the address to the EPIA (EM6000) client. For the rest of this message here are some setup details:

Mythbackend and dhcp server: 192.168.1.60
Target Mythfrontend: 192.168.1.155

I have my tftp-root directory set for /tftpboot and the following directory stucture is present:
/tftpboot/PXEClient/pxelinux.cfg/default
/tftpboot/PX/tftpboot/PXEClient/pxelinux.cfg
/tftpboot/PXEClient/bzImage
/tftpboot/PXEClient/rootfs

I downloaded the latest pxelinux.0 file from syslinux-2.08

Here is the relevant line from inetd.conf
tftp dgram udp wait nobody /usr/sbin/tcpd in.tftpd -s /tftpboot

Here's my dhcpd.conf

ddns-update-style none;

subnet 192.168.1.0 netmask 255.255.255.0 {
#default gateway
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;

group {
use-host-decl-names on;
option log-servers 192.168.1.60;

host myth1 {
hardware ethernet 00:40:63:c3:8c:3c;
next-server 192.168.1.60;
fixed-address 192.168.1.155;
filename "PXEClient/pxelinux.0";
}
}
}

On my client I get the Client IP 192.168.1.155, MASK 255.255.255.0 DHCP IP 192.168.1.60
GATEWAY 192.168.1.1

It then starts with:
TFTP...

but all I get is:
PXE-E32: TFTP open timeout

Any ideas?

Thanks

Darrick

Posted: Mon Dec 15, 2003 6:36 am
by lmatter
you could try tftp from your server (to itself) to see if it is working. Also check /var/log/messages.

Lastly, check the thread on LAN problems just in case.

Your tftp setup is different than mine so I can't really help with that.

Larry

Posted: Mon Dec 15, 2003 8:02 am
by dhartman
The problem seems to be with tftpd. I do not see messages generated in /var/log/messages though. I tried connecting to the tftp server manually and am unable to transfer files.

Enough beating my head against the wall for one night though...I'll look at it another night.

Darrick

Posted: Mon Dec 15, 2003 6:57 pm
by dhartman
OK. I got it going. I had to change the tftpd to root permissions instead of nobody (which I'll figure out what's up with that later).

New problem is related to mysql so I'll post a note in the main "help" forum.

Darrick