Page 1 of 1

Kernel panic: unable to mount root fs

Posted: Sun Nov 23, 2003 1:22 am
by tibor
Hey all,
Can't get minimyth to boot. It boots the kernel just fine, but kernel panics and cant find the rootfs. In the tftpd log i see it request the kernel, but it doesn't seem to request the rootfs.
Here is my pxelinux.cfg/default append line:

APPEND initrd=rootfs ramdisk_blocksize=4096 ramdisk=31000 devfs=mount LIRC=pctv MYTHSERVER=192.168.0.50

I am using the stock rootfs image, but I dpn't think it is even downloading it.
Any ideas?
Thanks

Posted: Sun Nov 23, 2003 4:32 am
by slifox
Makes sure you've got all your files in the right place. If it actually needed to download something but had a problem, the bios would've complained before linux even got a chance to start up. Also, (just a note) you don't need to set ramdisk to 31000 unless you're planning on putting in another 3-4mb of stuff. I've got mine set to 28000 because the stock rootfs is 25MB.

My tftp dir structure looks like this:

/var/lib/tftpboot/PXEClient/
bzImage pxelinux.0 pxelinux.cfg rootfs

/var/lib/tftpboot/PXEClient/pxelinux.cfg/
default

Hope this helps!
-alex

Posted: Sun Nov 23, 2003 4:41 am
by tibor
I am missing the pxelinux.cfg file under /tftpboot/PXEClient. What is in this file and where do I get it from.
Other than that I have all those files there, but it still gets the same error message. I got my pxelinux.0 file from syslinux-2.06 if that matters.
Thanks for you help.

Posted: Sun Nov 23, 2003 5:17 am
by lmatter
pxelinux.cfg is a directory, and a file named default goes in there. You can download default from the home page (you will need to edit it). Make sure you've read over these steps carefully.

Good luck,
Larry

Posted: Sun Nov 23, 2003 5:29 am
by tibor
Figured it out!
PXEClient/pxelinux.cfg on slifox's machine was probably just a symlink to ../pxelinux.cfg.
I created that link and everything worked.
I guess it was trying to download PXEClient/pxelinux.cfg/default
Is that the way it is supposed to work?

Posted: Sun Nov 23, 2003 5:41 am
by slifox
Well if it works, then good enough. However, on my machine the 'pxelinux.cfg' directory isn't a link, and neither is the 'default' file within it.

-alex