EPIA DVI modules with Openchrome

Ask for hardware advice here

Moderator: Pablo

Post Reply
hads
Member
Posts: 16
Joined: Tue Feb 06, 2007 9:45 pm

EPIA DVI modules with Openchrome

Post by hads » Mon Feb 26, 2007 11:48 pm

Hi all,

Does anyone have a DVI module working with minimyth? I have a EK10000G with a DVI-03 module and cannot get X to output to the TV connected to the DVI port at all. The POST and boot splash display fine but not X.

I've posted to the openchrome mailing list and got a few replies but nothing that helped me to get it working.

I saw a post by someone with a SP series board which should have the same chipset and they had it working but there isn't much info around.

Anyone know if this is supported or not or if there is something that I am doing wrong?

Here are the config and logs from minimyth;

http://mail.nice.net.nz/xorg.conf
http://mail.nice.net.nz/Xorg.0.log

I'd be very grateful for any pointers.

Cheers,

hads

George
New Member
Posts: 1
Joined: Wed Feb 28, 2007 10:17 pm

Post by George » Wed Mar 28, 2007 11:34 am

Did you get this working? I have an SP8000 with DVI02 daughterboard connected to a Sony SDM 74 via DVI. I had to obtain a bios upgrade from via tech support (and then work out how to apply it without use of a floppy drive - I used a windows boot CD to get a DOS prompt with CDROM support and ran the bios tool from a CD I burnt.). Once the bios was upgraded it just worked.

However I haven't tested very fully . . . I need to do a backend upgrade before I can test TV viewing. (Todays job?)

I created a temporary knoppmyth backend on a spare box (with no tuners) to test mythvideo and had problems with the internal player (green lines all over the display) but using either mplayer or xine resolved this.

seth_keith
Contributor
Posts: 131
Joined: Fri Mar 09, 2007 8:13 pm

DVI support on EX10000EG

Post by seth_keith » Thu Apr 19, 2007 2:07 am

does anyone have DVI output working with minimyth on EX10000EG or any other via motherboards?

rogerjames99
Member
Posts: 32
Joined: Sat Jan 12, 2008 1:53 am

Post by rogerjames99 » Wed Jan 16, 2008 2:12 pm

I just received a note from my local via dealer that DVI-02 boards on newer SP8000 boards do not need the 1.08 bios. There is in fact a pair of jumpers just beneath and to the left of the F_PANEL jumper both of which need to be fitted for DVI-02 boards and just the right one for LVDS-06 boards. I have not tested this yet, but post it here for info. Has anyoneelse tried this out.

rogerjames99
Member
Posts: 32
Joined: Sat Jan 12, 2008 1:53 am

Post by rogerjames99 » Wed Jan 16, 2008 6:38 pm

I have now tried the jumper setting and it still does not make things work. No boot up display with DVI enabled in the bios, but once the os driver gets loaded the monitor now complains that it is getting an out of range signal on the DVI interface and asks for the computer settings to be changed to 1680 x 1050 at 60Hz (the monitor default). I will get back onto the dealer and see if I can persuade them to send me a 1.08 bios.

rogerjames99
Member
Posts: 32
Joined: Sat Jan 12, 2008 1:53 am

Post by rogerjames99 » Fri Jul 18, 2008 5:48 pm

An update on my sp8000 dvi-02 setup. I now have this working with my Samsung LE26R8 television and the picture is superb. I eventually sent my SP8000 back to the distributor for them to have a look at it. They put it on the bench and confirmed that the DVI output was not working. They then reflashed the 1.07 BIOS with a fresh copy. At which point the DVI output burst into life. Thye then checked the other SP8000 boards they had in stock and found that none of them produced DVI output either until they had been reflashed. So it looks like there are a number of SP8000 boards out there with a rogue version of the 1.07 bios!

When I got my box back from them I fired up minimyth and now I could see the boot and minimyth loading on the TV via a DVI connector but as soon as X started the screen went blank. I tried a few things but could not get X to work, so I put it on the back burner and used the VGA connection instead.

I recently decided to try again, so it set up the box in the workshop connected to my Dell monitor via a DVI cable I booted it up expecting to see nothing, but lo and behold I had an X display. The resolution was a bit off, but it was working. The funny thing was that I still had minimyth.conf set up for VGA output. Experiementation proved that I could only get reliable DVI ouput provided I did NOT set MM_X_OUTPUT_DVI, did not do any messing about with VBEModes, and left MM_X_OUTPUT_VGA='auto'.

So I connected it back to the TV, still no output on the dvi, but it was a black screen rather than "no signal". So it must be the modeline.

Next step I connected a windows PC to the TV and ran moninfo (http://www.entechtaiwan.com/files/moninfo.exe). I checked the modeline it gave me and it looked identical to the one I was using. I then noticed one small difference I had +Hsync +Vsync, moninfo gave +hsync +vsync. I changed them to all lower case and it all burst into life. Strange that it worked on the Dell. The OpenChrome driver must be picky.

For info the MM_X_MODELINE that worked for the Samsung was.

"1360x768" 85.5 1360 1424 1536 1792 768 771 777 795 +hsync +vsync"

Messing about trying to derive 1080p modelines did not work.

So my conclusion on DVI-02 daughter boards is:

Dont tell the OpenChrome driver to use DVI it will fail with the "Panel not found" message;
The OpenChrome driver cannot read any EDID data via the DVI connector, you must supply a valid modeline found out by some other means;
If you cannot see DVI output of the boot process then reflash the 1.07 bios;
Oh and you must have the jumpers fitted I mentioned earlier in this thread.

Roger

paddy
Member
Posts: 21
Joined: Tue Jul 01, 2008 12:51 pm
Location: UK

Post by paddy » Fri Sep 12, 2008 9:26 pm

RogerJamees99,

Hi, it looks like a have a very similar setup with a sammy LE26r87 which was working fine with VGA, but using DVI the picture is too big to put on screen. I have tried various settings but cant fix it. Can you post your minimyth.conf file so I can crib off it. Cheers

Post Reply