The End of XvMC and XvMC-VLD

Announcements!

Moderator: Pablo

Locked
Pablo
Site Admin
Posts: 4182
Joined: Tue Dec 14, 2004 2:13 am
Location: La Jolla
Contact:

The End of XvMC and XvMC-VLD

Post by Pablo » Sun Jan 02, 2011 1:30 am

It is the end of an era. The end of XvMC (including XvMC-VLD) is on the horizon. It is being replaced by VDPAU and VA-API.

With this commit, MythTV has begun the removal of support for XvMC (including XvMC-VLD). As a result, once MythTV 0.25 is released, MythTV will no longer have support for XvMC (including XvMC-VLD).

Unfortunately, this means that MiniMyth users with VIA EPIA hardware that rely on XvMC-VLD hardware acceleration will not be able to upgrade beyond MythTV 0.24. Sadly, VIA has provided no useful support to the Open Source graphics developers. As a result, in addition to the Open Source graphics drivers currently having no path to supporting newer VIA hardware, the Open Source graphics drivers currently have no path to supporting either the VDPAU of VA-API interfaces.

For those looking for smaller form factor, lower power hardware, the only hardware that I can suggest is hardware that combines the Intel Atom CPU with the NVIDIA ION GPU. While this hardware consumes more power, the GPU supports the VDPAU interface and is able to decode high definition H.264 video.
MiniMyth running on an Acer ApireRevo 3610 and a Zotac ZBOX-ID80-U. Find out more at my MythTV page.

Locked