mame without building minimyth

Share your success stories with others

Moderator: Pablo

Post Reply
Posts: 131
Joined: Fri Mar 09, 2007 8:13 pm

mame without building minimyth

Post by seth_keith »

First off let me say I cannot make the build system work because of my broken network, so I am forced to do this hack. If you want to try it, you may be able to get mame working on minimyth a lot faster than making the build system work. However, you should make the build system work if possible. Also if the build system can work without a network someone please tell me how and I'll get my head out of me arse.

I think this approach should work for any VIA EPIA <= i586

Here is what I did:

#1 - look for a sdlmame .i386 package for my back end distribution ( in my case fedora core 6 ). I found one for fc5, it installed fine anyway.

#2 - copy sdlmame from the backend /usr/bin to a shared location where your frontend can get to it.

#3 - Resolve any missing library binaries. I had NO library requirements, but I already have my minimyth patched to use the necessary firefox libraries. All binaries for firefox are still available from user: pwd: take out the @.... part. The file is ff.tar.bz2

#4 - create a /mnt/game/mame/roms directory

#5 - put teeter torture legal rom available from:

into /mnt/game/mame/roms. Put the whole .zip file there. Do not unzip it.

#6 Create new emulator settings for .zip extension. The command to play is:


The rom path is:


Other settings do not matter.

#7 Don't forget to scan for new games!

I think that is it. This worked for about 40% of all mame games tried.

The rest just failed inexplicably... If I somehow build sdlmame should I have better luck, or do many of these games not work with sdlmame. I get the game loaded, then it just exists.
Posts: 54
Joined: Mon Jul 16, 2007 1:55 am
Location: Planet Earth

Post by ledhed »

I just want to say thanks for your post.

Using your method I was able to get XMame working on all of my frontends.

I installed the XMame package on my backend, then copied all the missing lib's to my /Extras/lib folder.

Works like a champ!!!

Thanks again.

Post Reply